Last Comment Bug 601570 - parallel xforms and schema-validation build sometimes fails due to race
: parallel xforms and schema-validation build sometimes fails due to race
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XForms (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla2.0b8
Assigned To: Philipp Wagner [:imphil]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-04 03:07 PDT by Philipp Wagner [:imphil]
Modified: 2010-11-06 04:34 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch to configure.in (1.54 KB, patch)
2010-10-04 11:07 PDT, Philipp Wagner [:imphil]
ted: review+
jst: approval2.0+
Details | Diff | Review
[for checkin] configure.in changes (1.64 KB, patch)
2010-10-14 15:36 PDT, Philipp Wagner [:imphil]
no flags Details | Diff | Review

Description Philipp Wagner [:imphil] 2010-10-04 03:07:49 PDT
Since bug 463385 modified extensions/Makefile.in to use PARALLEL_DIRS instead of DIRS for all extensions we have a race condition when doing parallel builds of schema-validation and xforms.

xforms (in http://hg.mozilla.org/xforms/file/3bd9353a5347/Makefile.in#l101) adds schema-validation to its DIRS, causing it to be built twice in parallel (once from extensions/Makefile and once from extensions/xforms/Makefile). This may work from time to time, but generally gives errors like this one:

/home/philipp/src/mozilla-central/obj-debug/config/nsinstall -R -m 644 /home/philipp/src/mozilla-central/extensions/schema-validation/public/nsISVSchemaErrorHandler.idl /home/philipp/src/mozilla-central/extensions/schema-validation/public/nsISVSchema.idl /home/philipp/src/mozilla-central/extensions/schema-validation/public/nsISVSchemaLoader.idl /home/philipp/src/mozilla-central/extensions/schema-validation/public/nsISchemaValidator.idl /home/philipp/src/mozilla-central/extensions/schema-validation/public/nsISchemaDuration.idl /home/philipp/src/mozilla-central/extensions/schema-validation/public/nsISchemaValidatorRegexp.idl ../../../dist/idl
/home/philipp/src/mozilla-central/obj-debug/config/nsinstall: cannot make symbolic link /home/philipp/src/mozilla-central/obj-debug/dist/idl/nsISVSchemaLoader.idl: File exists
make[6]: *** [export] Fehler 1
make[6]: Leaving directory `/home/philipp/src/mozilla-central/obj-debug/extensions/schema-validation/public'


Neil, since you made this change initially, do you have an idea how to solve this? Or could you CC someone else that might know how? ;)
Comment 1 Philipp Wagner [:imphil] 2010-10-04 03:11:50 PDT
ah wrong bug, I meant bug 462381 and that means Mitchell instead of Neil. The question above stays the same. Sorry for the confusion.
Comment 2 neil@parkwaycc.co.uk 2010-10-04 03:31:46 PDT
Ah, so xforms depends on schema-validation, and unconditionally builds it? Can you not remove schema-validation from your --enable-extensions list?
Comment 3 Philipp Wagner [:imphil] 2010-10-04 11:06:43 PDT
Thanks Neil, that seems to work indeed (simple and easy!) It only needs a small patch to the configure.in to remove the enforcement of that schema-validation dependency. I've attached a patch, but I'll do some more tests on different platforms before asking for review on this one.
Comment 4 Philipp Wagner [:imphil] 2010-10-04 11:07:24 PDT
Created attachment 480666 [details] [diff] [review]
patch to configure.in
Comment 5 Philipp Wagner [:imphil] 2010-10-12 14:26:51 PDT
Comment on attachment 480666 [details] [diff] [review]
patch to configure.in

Requesting approval2.0 because we need this for XForms to build reliably with Gecko 2.0.
Comment 6 Philipp Wagner [:imphil] 2010-10-14 15:36:57 PDT
Created attachment 483317 [details] [diff] [review]
[for checkin] configure.in changes
Comment 7 alexander :surkov 2010-10-14 19:02:13 PDT
Philipp, did you start try server build? That's good guarantee the patch is safe to checkin?
Comment 8 Philipp Wagner [:imphil] 2010-10-15 15:08:39 PDT
yes, it builds on all platforms.
Comment 9 alexander :surkov 2010-11-05 21:14:05 PDT
landed http://hg.mozilla.org/mozilla-central/rev/71db9b08ee9a

Note You need to log in before you can comment on or make changes to this bug.