Altering left and clip values of div sometimes produces flickering

VERIFIED DUPLICATE of bug 36849

Status

()

P3
normal
VERIFIED DUPLICATE of bug 36849
18 years ago
18 years ago

People

(Reporter: conorlennon, Assigned: attinasi)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I'm seeing this in Build 2000111404 in WinNT SP5

When I alter the clip and left style values of a div element, the intermediate
position is briefly displayed, i.e. with the altered clip value but the old left
value.
IE5 only displays after both values have been changed.
This may be due to Mozilla being faster, but it does produce ugly flickering.

I have a testcase which displays a portion of the image form the top of the
mozilla.org page.
Javascript is used to switch between showing 100 pixels starting 400 pixels
over, shifted back 200 pixels and showing 100 pixels starting 200 pixels not
shifted back.
This should alternate showing each 100 pixels on top of each other.
However, you can sometimes see the image after the clip has been applied but
before the x value is altered.  This manifests itself as an image either 200
pixels to the left or the right of where the image should be.

Its hard to explain in words, but a picture tells a 1000 words, so have a look
at the attachment.
(Reporter)

Comment 1

18 years ago
Created attachment 19262 [details]
testcase to demonstrate problem

Comment 2

18 years ago
Confirmed
Mozilla build: 2000111404
OS: WindowsNT (SP5)

Comment 3

18 years ago
Confirmed.
OS: Windows 98
Platform: PC
Mozilla Build: 2000112704 M18 Trunk Build.

Marking as NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Mark, IIRC you've dealt with similar flickering bugs already, could you look
into this one?
Assignee: jst → attinasi
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 36849 ***

Comment 6

18 years ago
marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.