four different text cursor appearances in a single address bar url edit

RESOLVED DUPLICATE of bug 574492

Status

Firefox for Android Graveyard
General
RESOLVED DUPLICATE of bug 574492
8 years ago
8 years ago

People

(Reporter: atoll, Unassigned)

Tracking

Trunk
ARM
Android

Details

0. Start Fennec.
1. Press on the address bar only once.

The tiny cursor described in #2 below appears momentarily, then disappears; keyboard input focus remains on the address bar.

2. Press on the address bar a second time.

The cursor that appeared momentarily in #1 appears again, and sticks around this time.  I see is a tiny vertical bar less than half the height of the address bar input field, pinned to the bottom of the field.

3. Type a letter.

At this stage, the cursor is sized appropriately for the address bar font, and vertically centered.

4. Delete the letter with the Delete key.

At this stage, the cursor is the full height of the field, pinned to top and bottom.
Sounds like a dupe of bug 574492
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 574492
Seems reasonable.  Note that #574492 covers #2, #3, and #4 but does not mention #1, where no cursor is shown at all after the initial first click on the address bar.
You need to log in before you can comment on or make changes to this bug.