Cannot open firefox after updating from alpha to beta on android

VERIFIED FIXED

Status

--
critical
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: ashah, Assigned: mwu)

Tracking

Trunk
ARM
Android

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Fennec is sucessfully updated from Alpha to Beta but it does not open after installation of beta.
When I tap on the firefox icon to open the application, it seems that it is opening firefox but it comes back to the android desktop. It does not open firefox.
(Reporter)

Updated

8 years ago
tracking-fennec: --- → ?
(Reporter)

Comment 1

8 years ago
To make things clear, this was a manual update. That means I downloaded the alpha from releases folder on ftp server. Then I downloaded the beta and installed beta on the top of alpha.
(Reporter)

Updated

8 years ago
Summary: Cannot open firefox after updating from alpha to beta → Cannot open firefox after updating from alpha to beta on android
I can confirm this, here's what I see in my log:

I/ActivityManager(   85): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App }
I/ActivityManager(   85): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=1329 uid=10056 gids={3003, 1015}
I/GeckoApp( 1329): create
I/GeckoAppJava( 1329): Checking for an update
D/dalvikvm( 1329): GC_FOR_MALLOC freed 2145 objects / 153280 bytes in 47ms
I/global  ( 1329): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
I/GeckoApp( 1329): cpu version: 7
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozalloc.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libmozalloc.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozalloc.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x449233d0, skipping init
I/GeckoApp( 1329): env0: null
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libnspr4.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libnspr4.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libnspr4.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libplc4.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libplc4.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libplc4.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libplds4.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libplds4.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libplds4.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozsqlite3.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libmozsqlite3.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozsqlite3.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libnssutil3.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libnssutil3.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libnssutil3.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libnss3.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libnss3.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libnss3.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libssl3.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libssl3.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libssl3.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libsmime3.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libsmime3.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libsmime3.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libxul.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libxul.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libxul.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libxpcom.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libxpcom.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libxpcom.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libnssckbi.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libnssckbi.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libnssckbi.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libfreebl3.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libfreebl3.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libfreebl3.so 0x449233d0, skipping init
D/dalvikvm( 1329): Trying to load lib /data/data/org.mozilla.fennec/lib/libsoftokn3.so 0x449233d0
D/dalvikvm( 1329): Added shared lib /data/data/org.mozilla.fennec/lib/libsoftokn3.so 0x449233d0
D/dalvikvm( 1329): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libsoftokn3.so 0x449233d0, skipping init
D/dalvikvm( 1329): GC_FOR_MALLOC freed 2309 objects / 169824 bytes in 35ms
I/global  ( 1329): Default buffer size used in BufferedInputStream constructor. It would be better to be explicit if an 8k buffer is required.
I/GeckoAppJava( 1329): Can't find components/ in /mnt/asec/org.mozilla.fennec-2/pkg.apk
I/GeckoApp( 1329): start
I/GeckoApp( 1329): resume
I/fennec  ( 1329): XRE_main returned 1
I/GeckoAppJava( 1329): XRE exited
I/GeckoAppJava( 1329): we're done, good bye
I/AndroidRuntime( 1329): AndroidRuntime onExit calling exit(0)
E/JavaBinder( 1329): Unknown binder error code. 0xfffffff7
E/JavaBinder( 1329): Unknown binder error code. 0xfffffff7
D/AndroidRuntime( 1329): Shutting down VM
W/dalvikvm( 1329): threadid=1: thread exiting with uncaught exception (group=0x4001d7f0)
I/ActivityManager(   85): Process org.mozilla.fennec (pid 1329) has died.
I/WindowManager(   85): WIN DEATH: Window{44c6efd0 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
I/WindowManager(   85): WIN DEATH: Window{44c5a648 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
I/UsageStats(   85): Unexpected resume of com.android.launcher2 while already resumed in org.mozilla.fennec
W/InputManagerService(   85): Window already focused, ignoring focus gain of: com.android.internal.view.IInputMethodClient$Stub$Proxy@44b9e7c8
I can work around this by going to settings->Applications->Manage Applications->Firefox and clicking the "Clear data" button. Of course this blows away the user's profile.

Updated

8 years ago
tracking-fennec: ? → 2.0b1+
(Assignee)

Updated

8 years ago
Assignee: nobody → mwu
(Assignee)

Comment 4

8 years ago
application.ini isn't updating.
the problem seems to be application.ini. Deleting that allows us to run.
(Assignee)

Comment 6

8 years ago
Created attachment 481094 [details] [diff] [review]
A simple fix
Attachment #481094 - Flags: review?(blassey.bugs)
Attachment #481094 - Flags: review?(blassey.bugs) → review+
(Assignee)

Comment 7

8 years ago
http://hg.mozilla.org/mozilla-central/rev/6bd3e0d8c5d1 (relbranch)
http://hg.mozilla.org/mozilla-central/rev/dee1e01fd8ed
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 8

8 years ago
I have the same issue with my samsung epic. I had the alpha version installed. I dowDownloaded from http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/4.0b1-candidates/build2/android-r7/

And it just says with a warning icon "Application not installed"
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #8)
> I have the same issue with my samsung epic. I had the alpha version installed.
> I dowDownloaded from
> http://ftp.mozilla.org/pub/mozilla.org/mobile/candidates/4.0b1-candidates/build2/android-r7/
> 
> And it just says with a warning icon "Application not installed"

entirely different bug that what was reported here
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
I'm seeing the same  "Application not installed" issue. Should a new bug be filed for this or has it been filed already?
(Assignee)

Comment 11

8 years ago
File a new bug.

Just verified this on my tegra board. This specific issue is fixed.
Status: RESOLVED → VERIFIED
Ok, I filed bug  602272 for it.
Also, I'd like to mention to please refrain from verifying a bug that you set to resolved. Fortunately, Naoki and I can verify this is not happening on the Nexus One and Droid 2. Follow up will need to be done for martijn's and matt's issue in bug 602272
Mozille/5.0 (Android; Linux armv71; rv:2.0b7pre) Gecko20101005 Firefox/4.0b7pre Fennec/4.0b1

Verified on droid 2 with these conditions :
1) alpha 1: blank profile, still running in background -> beta 1 rc 2 = works
2) alpha 1: profile w/ bookmarks, still running -> beta 1 rc 2 = works, see bookmarks
3) alpha 1: profile w/ sync account, still running -> beta 1 rc 2 =works, sync account listed.
4) alpha 1: no profile, not running -> beta 1 rc 2 = works
5) alpha 1: sync, not running -> beta 1 rc 2 = works, sync account listed.

Note:  
for condition 3, 5 : unfortunately alpha 1 sync doesn't work with current sync servers.
You need to log in before you can comment on or make changes to this bug.