Closed Bug 602019 Opened 9 years ago Closed 9 years ago

File upload stops screen from updating except when there is input

Categories

(Firefox :: General, defect, major)

4.0 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 627084

People

(Reporter: stevethepocket, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b6) Gecko/20100101 Firefox/4.0b6

This is really weird, but in the last couple days I've been getting a bug where the screen will stop refreshing itself. Animated GIFs stop moving, the typing cursor stops flashing, and if I click a link, the new page will not appear on the screen. UNLESS, I move the mouse, click a mouse button, use the scroll wheel, or use the keyboard.

For example: If I click a link and let go of the mouse for about ten seconds and then move it again, the new page will appear all at once. GIFs advance to the next frame every time I move the pointer by one pixel, unless I am moving it faster than the GIF's normal framerate. You can substitute clicks, scrolls, or key presses for mouse movement, including holding down keys like Shift. With Smooth Scrolling on, if I flick the wheel even one notch, the screen will refresh constantly during the scroll animation.

It's NOT just the viewport that's affected by this: progress bars and progress icons in the tab bar also follow this, making the entire program appear frozen even though it is not. The only thing unaffected by this is Flash (and possibly other plugins; I haven't checked), which will play in real time with no input even while the rest of the screen appears frozen (although it's got its own issues with responsiveness).

This does not happen as soon as I start Firefox, but I haven't been able to nail down what triggers it yet. Oddly enough, this also just started happening yesterday, even though I have had this version of the beta since it came out. I have restarted Firefox since it started happening, and the problem has not gone away.

Reproducible: Sometimes

Steps to Reproduce:
1. Use FF beta 6 for a certain length of time.
2. Go to a page with animated GIFs.
Actual Results:  
The GIFs will not animate except when the mouse is moving, or being clicked, or scrolled with, or keys are being pressed.

Expected Results:  
The GIFs should be animating even when there is no input.

I should probably mention that I have DirectDraw on. I have not yet tried using the browser with it turned off.
Same here! 
The whole browser works fine, except, that it stops doing anything if no user input is given. And it seems like every mousemove, mouseclick, keypress (and so on) event steps it just a little bit forward. In effect every operation takes... well, not forever, but a whole lot longer than it used to.
The other effect is, if i type an URL, and not move anything after pressing return, then after some time i get the message: server did not respond. The same URL works fine if i just move the mouse.
I probably should mention, i'm running Minefield Nightly on Win7 x64.

Cheers
Wojtek
Updated to Beta 10 after the last two or three betas not having this issue at all, and it's back. I've had it open since the update was first applied yesterday, so this is a first-session occurrence.

Also (and this may have applied to the first time I had the bug), tooltips on elements with the title attribute don't pop up at all once this kicks in.
Still in Beta 12, worse than ever now. It's starting to kick in after less than an hour.
New development! I've narrowed it down to only kicking in after uploading a file. Not every time I upload a file, but that's always what triggers it. Continuing to investigate.
Just to update, i had the same problem, but it gone away with beta 11 (AFAIR).
But until then i noticed an interesting pattern. The no-refresh behavior was there every time i started the browser, it was not connected to any action i made while browsing. And it was possible, that it was suddenly gone after a few hours of work.
But, I figured out how to easily get rid of this pain. You just need to start the browser from another program, like RSS Agregator. If Firefox has a web page to load right from the start, then all refresh problems are gone. Did not try this with an home page set up, as I usually use just about:blank.
Summary: Screen refresh halts when there is no input → File upload stops screen from updating except when there is input
Still present in release candidate. This might be more likely to get noticed by the right people if there were an option in the Version dropdown for 4.0 pre. Is there somewhere else I should be posting this?
Persists in release candidate 2, and confirmed as not the result of third party add ons.
Version: unspecified → 4.0 Branch
This bug was reported using a pre-release version of Firefox 4. Now that Firefox 4.0.1 final has been released, can you please update and retest your bug? A fresh profile would be a good starting place to test, 
http://support.mozilla.com/kb/Managing+profiles. If you continue to see the issue, can you please update this bug with your results?

Filter: firefox4prebugsunco
I was getting this on 4.0 and 4.0.1 (which I have replaced with 5.0 beta now). I'm currently still getting this on 5.0 beta, aurora and nightly, each with their own separate profiles.

Also had this on 3.6 which was using a different profile (started with a new profile on 4.0) and remember 3.5 having this issue as well.

It's also triggered for me when uploading a file. So I'm currently forced to use a separate browser (like nightly) to upload something so I don't have to restart my main browser and reload the many tabs I work with.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 627084
You need to log in before you can comment on or make changes to this bug.