crash [@ js_NewGCString(JSContext*) ] [@ js_NewGCString ]

RESOLVED WORKSFORME

Status

()

defect
--
critical
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: scoobidiver, Assigned: dmandelin)

Tracking

({crash, regression})

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(blocking2.0 beta8+)

Details

(crash signature)

(Reporter)

Description

9 years ago
Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b7pre) Gecko/20101005 Firefox/4.0b7pre

It is a new crash signature. Crashes first started on b7pre/20100925 build. The daily rate is too low to determine a short regression range.
It happens mainly at start-up and on Windows 7.
It is #2 top crasher in b7pre/20101005 build.

Signature	js_NewGCString(JSContext*)
UUID	33bac18e-0a2b-44c8-9028-86cd92101005
Time 	2010-10-05 23:46:14.115188
Uptime	2
Last Crash	5 seconds before submission
Install Age	48991 seconds (13.6 hours) since version was first installed.
Product	Firefox
Version	4.0b7pre
Build ID	20101005041637
Branch	2.0
OS	Windows NT
OS Version	6.1.7600
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 10
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xc0
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0428

Frame 	Module 	Signature [Expand] 	Source
0 	mozjs.dll 	js_NewGCString 	js/src/jsgcinlines.h:95
1 	mozjs.dll 	js_NewDependentString 	js/src/jsstr.cpp:3502
2 	mozjs.dll 	js::RegExp::createResult 	js/src/jsregexpinlines.h:252
3 	mozjs.dll 	js::RegExp::executeInternal 	js/src/jsregexpinlines.h:339
4 	mozjs.dll 	regexp_exec_sub 	js/src/jsregexp.cpp:819
5 	mozjs.dll 	js_regexp_exec 	js/src/jsregexp.cpp:836
6 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4625
7 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
8 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:746
9 	mozjs.dll 	js_fun_call 	js/src/jsfun.cpp:2288
10 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4625
11 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
12 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:746
13 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:776
14 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4836
15 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1694
16 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:571
17 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
18 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
19 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
20 	xul.dll 	nsThread::ThreadFunc 	xpcom/threads/nsThread.cpp:263
21 	nspr4.dll 	_PR_NativeRunThread 	nsprpub/pr/src/threads/combined/pruthr.c:426
22 	nspr4.dll 	pr_root 	nsprpub/pr/src/md/windows/w95thred.c:122
23 	mozcrt19.dll 	_callthreadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:348
24 	mozcrt19.dll 	_threadstartex 	obj-firefox/memory/jemalloc/crtsrc/threadex.c:326
25 	kernel32.dll 	BaseThreadInitThunk 	
26 	ntdll.dll 	__RtlUserThreadStart 	
27 	ntdll.dll 	_RtlUserThreadStart 	

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=js_NewGCString%28JSContext*%29
(Reporter)

Updated

9 years ago
blocking2.0: --- → ?

Updated

9 years ago
blocking2.0: ? → beta8+

Comment 1

9 years ago
Gregor, can you take a look? Any idea?
This might be an old bug. I see crashes in js_NewGCString even in 3.6 releases. But they seem to be more frequent now and windows related.
I will see if I can get access to a windows machine.
(Reporter)

Updated

9 years ago
OS: Windows 7 → All
Summary: crash mainly at start-up [@ js_NewGCString(JSContext*) ] → crash mainly at start-up [@ js_NewGCString(JSContext*) ] [@ js_NewGCString ]

Comment 3

9 years ago
the  js_NewGCString(JSContext*) signature had a bit of a bump on the trunk when this bug was filed, then it tappered off a few days later.  

date     tl crashes at, count build, count build, ...
         js_NewGCString.JSContext..
20101001 3  1 4.0b7pre2010100108, 
	        1 4.0b7pre2010093004, 1 4.0b7pre2010092904, 
20101002 8  4 4.0b7pre2010100204, 
	        4 4.0b7pre2010100108, 
20101003 8  4 4.0b7pre2010100204, 
	        3 4.0b7pre2010100304, 1 4.0b7pre2010093004, 
20101004 8  3 4.0b7pre2010100404, 
	        2 4.0b7pre2010100304, 2 4.0b7pre2010093004, 
	        1 4.0b7pre2010100204, 
20101005 18  13 4.0b7pre2010100504, 
	        5 4.0b7pre2010100204, 
20101006 9  6 4.0b7pre2010100604, 
	        2 4.0b7pre2010100504, 1 4.0b7pre2010100204, 
20101007 15  8 4.0b8pre2010100704, 
	        7 4.0b7pre2010100604, 
20101008 15  7 4.0b8pre2010100804, 
	        7 4.0b8pre2010100704, 1 4.0b7pre2010100604, 
20101009 8  6 4.0b8pre2010100904, 
	        1 4.0b7pre2010100604, 1 4.0b7pre2010100304, 

but on the 15th it started a more sustained climb in volume.  now its ranked #10 topcrash on trunk and it looks like it only appears there.


20101013 6  4 4.0b8pre2010101304, 
	        1 4.0b8pre2010101104, 1 4.0b7pre2010100304, 
20101014 11  6 4.0b8pre2010101404, 
	        2 4.0b8pre2010101322, 2 4.0b8pre2010101304, 
	        1 4.0b8pre2010101204, 
20101015 23  22 4.0b8pre2010101504, 
	        1 4.0b8pre2010101404, 
20101016 37  21 4.0b8pre2010101604, 
	        16 4.0b8pre2010101504, 
20101017 42  21 4.0b8pre2010101704, 
	        19 4.0b8pre2010101604, 2 4.0b8pre2010101504, 
20101018 52  32 4.0b8pre2010101804, 
	        19 4.0b8pre2010101704, 1 4.0b8pre2010101604, 
20101019 49  23 4.0b8pre2010101904, 
	        19 4.0b8pre2010101804, 6 4.0b8pre2010101704, 
	        1 4.0b8pre2010101604, 
20101020 60  27 4.0b8pre2010101904, 
	        19 4.0b8pre2010102004, 5 4.0b8pre2010102012, 
	        5 4.0b8pre2010101804, 3 4.0b8pre2010101704, 
	        1 4.0b8pre2010101604, 
20101021 46  27 4.0b8pre2010102104, 
	        13 4.0b8pre2010102012, 4 4.0b8pre2010102004, 
	        2 4.0b8pre2010101904, 
20101022 56  25 4.0b8pre2010102104, 
	        21 4.0b8pre2010102204, 5 4.0b8pre2010102012, 
	        2 4.0b8pre2010102004, 1 4.0b8pre2010102205, 
	        1 4.0b8pre2010101904, 1 4.0b8pre2010101804, 
20101023 40  18 4.0b8pre2010102204, 
	        17 4.0b8pre2010102304, 2 4.0b8pre2010102104, 
	        1 4.0b8pre2010102004, 1 4.0b8pre2010101804, 
	        1 4.0b8pre2010101604, 


This is probably a dup or depends on bug 604756

js_NewGCString.JSContext.. is 

4.0b8pre only

not a start up crash
 Correlation to startup or time of session
 40 total crashes for js_NewGCString.JSContext.. on 20101023-crashdata.csv
 6 startup crashes inside 30 sec.
 13 startup crashes inside 3 min.
 3 repeated crashes inside 3 min. of last crash

os breakdown
js_NewGCString.JSContext..Total 40
Win5.1  0.17
Win6.0  0.03
Win6.1  0.80
Depends on: 604756
this happened for me while using the buildbot web interface actively and a bunch of background tabs.  I dont think that the buildbot web interface actually uses javascript, so i doubt it was content.

http://crash-stats.mozilla.com/report/index/5f72f79e-0ccb-44f6-a935-707c52101026
I hit this yesterday. IIRC, I wasn't actively using the browser at the time, but it's clearly executing JS, so it might have been gmail or zimbra.
http://crash-stats.mozilla.com/report/index/bp-0838fe44-de92-448b-accc-1365e2101026

Updated

9 years ago
Depends on: 608109

Updated

9 years ago
No longer depends on: 608109

Updated

9 years ago
Depends on: 608142

Updated

9 years ago
No longer depends on: 608142
(Assignee)

Comment 8

9 years ago
This became much less common in builds on/after 10/29. Most of them in recent days were probably from background-threading-related causes. I'll keep watching to see if it stays low over the next week.
Summary: crash mainly at start-up [@ js_NewGCString(JSContext*) ] [@ js_NewGCString ] → crash [@ js_NewGCString(JSContext*) ] [@ js_NewGCString ]
(Assignee)

Updated

9 years ago
Assignee: general → dmandelin
(Assignee)

Comment 9

9 years ago
Not seen in any build after 10/30. Reopen if it comes back.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ js_NewGCString(JSContext*) ] [@ js_NewGCString ]
You need to log in before you can comment on or make changes to this bug.