The default bug view has changed. See this FAQ.

PGO builds fail with --enable-tests where SIMPLE_PROGRAMS are linked against objects compiled with -fprofile-generate

RESOLVED FIXED in mozilla6

Status

()

Core
Build Config
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: Chris Coulson, Assigned: glandium)

Tracking

Trunk
mozilla6
All
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
Created attachment 481263 [details]
Build failure

I tried doing a profiledbuild with latest mozilla-central. I get a build failure when trying to link nsIFileEnumerator (I've attached the error).

The issue seems to be that the objects in libxpcomglue_s are compiled with -fprofile-generate, but the linking is done without (as a side-effect of bug 542504).

The GCC manual states "You must use ‘-fprofile-generate’ both when compiling and when linking your program."
(Reporter)

Updated

7 years ago
Blocks: 542504
(Reporter)

Updated

7 years ago
Attachment #481263 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 1

7 years ago
Urgh, and, of course - I meant to say "--enable-tests" ;)
I guess we should fix it the way I said in bug 542504 comment 3 instead. :-/
(Assignee)

Updated

6 years ago
Duplicate of this bug: 642461
(Assignee)

Updated

6 years ago
Summary: PGO builds fail with --disable-tests where SIMPLE_PROGRAMS are linked against objects compiled with -fprofile-generate → PGO builds fail with --enable-tests where SIMPLE_PROGRAMS are linked against objects compiled with -fprofile-generate
(Assignee)

Updated

6 years ago
Assignee: nobody → mh+mozilla
(Assignee)

Updated

6 years ago
Depends on: 643817
(Assignee)

Comment 4

6 years ago
Created attachment 521477 [details] [diff] [review]
Don't build SIMPLE_PROGRAMS during MOZ_PROFILE_GENERATE pass
Attachment #521477 - Flags: review?(ted.mielczarek)
(Assignee)

Comment 5

6 years ago
Created attachment 521543 [details] [diff] [review]
Don't build SIMPLE_PROGRAMS during MOZ_PROFILE_GENERATE pass

The previous iteration led to a failure to build on windows due to xpcom/tests/windows/Makefile.in including config.mk before setting CPP_UNIT_TESTS.
Attachment #521477 - Attachment is obsolete: true
Attachment #521543 - Flags: review?(ted.mielczarek)
Attachment #521477 - Flags: review?(ted.mielczarek)
Attachment #521543 - Flags: review?(ted.mielczarek) → review+
(Assignee)

Updated

6 years ago
Blocks: 559964
(Assignee)

Comment 6

6 years ago
http://hg.mozilla.org/mozilla-central/rev/1203611ef3dc
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla6
You need to log in before you can comment on or make changes to this bug.