nanojit: print all hex numbers in LIR dumps with an 0x prefix

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
5 years ago

People

(Reporter: njn, Assigned: njn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed-in-nanojit)

Attachments

(1 attachment)

(Assignee)

Description

8 years ago
Created attachment 481401 [details] [diff] [review]
patch (against TM 54893:b75687a3151e)

If all hex numbers in LIR dumps are printed with an 0x prefix, it makes it easier to strip out addresses, which is important when comparing two dumps for differences.  This patch does this for the i386 backend.  (I also checked the X64 backend, it didn't need changing.)
Attachment #481401 - Flags: review?(rreitmai)

Updated

8 years ago
Attachment #481401 - Flags: review?(rreitmai) → review+

Comment 1

8 years ago
dup bug 549248?
(Assignee)

Updated

8 years ago
Duplicate of this bug: 549248

Comment 5

8 years ago
http://hg.mozilla.org/mozilla-central/rev/4b961df303b2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Component: Nanojit → Nanojit
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.