Reload doesn't reflect changes to text <input>'s

VERIFIED DUPLICATE of bug 46845

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 46845
17 years ago
16 years ago

People

(Reporter: jks, Assigned: rods (gone))

Tracking

Trunk
mozilla1.0
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.15 i686)
BuildID:    2000101015

When you change the value of a text <input> and hit reload the changes don't get
made on the displayed.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.selectacast.net/~jks/mozillatest2.html
2.  Download the html so you can play with the html
3.  View the page in your browser
4.  fiddle with the inputs
5. Reload the page in your browser.

Actual Results:  See http://www.selectacast.net/~jks/mozillatest2.html

Expected Results:  The inputs should have the new value in the html.

I found this bug trying to replicate a different bug.  The original bug I was
trying to replicate was that readonly fields could be modified by dragging text
into them.  For some reason I couldn't replicate that bug on this page.

Comment 1

17 years ago
Confirming on WinNT with 2000110509 commercial binary. Changing OS to "All".


Steps to reproduce: 

1. Go to the given URL, save the HTML file locally, and load it in the browser.
2. Open the HTML file in a text editor, change the value of an input, and save.
3. Hit "Reload" in the browser: the new value of the input is not shown.



Compare bug 33534, which is a similar issue involving applets.



NOTES:

1. The same thing also occurs for me in NN4.7, exactly as in N6: 
   reload alone doesn't load the changes correctly.

2. In both NN4.7 and in N6, SHIFT + reload loads the changes correctly

3. In IE4.7, reload alone loads the changes correctly
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 2

17 years ago
Cache bugs to Gordon
Assignee: neeti → gordon
Target Milestone: --- → mozilla1.0

Comment 3

16 years ago
This is not a cache bug.  The behavior seems consistent with 4.x and 6.0.  
Perhaps this is an RFE?
Assignee: gordon → rods
Component: Networking: Cache → HTML Form Controls
QA Contact: tever → vladimire
(Reporter)

Comment 4

16 years ago
This is a bug.  It might be a chache bug or it might be a forms control bug but
it is *not* and RFE.

Comment 5

16 years ago
This looks like a duplicate of bug 46845

Comment 6

16 years ago
Similar thing happening here with Moz 0.9.1 (Mozilla/5.0 (Windows; U; Win98;
en-US; rv:0.9.1) Gecko/20010607) Build ID:2001060703 on Windows98

I can change data and resubmit the form but the resulting page will display the
data I previously submitted.
However, it only happens two out of every five times.

(Assignee)

Comment 7

16 years ago
works for me
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 8

16 years ago
reopening to make dupe of 46845

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 9

16 years ago

*** This bug has been marked as a duplicate of 46845 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
verifying
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.