Confusing error messages when Desktop has not yet fully synced

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

unspecified
Other
iOS 3
Points:
---
Bug Flags:
blocking-fx-home1.0.4 +

Firefox Tracking Flags

(Not tracked)

Details

1. on home log into account :
nh.test@yahoo.com
T3st1ngs
hgzqa-apxvw-vlhfa-hosco
2. on desktop machine log into the same account and add some more bookmarks, web browsing etc and sync
3. while the sync is taking place (on the desktop go to about:sync-log), refresh the sync on home
Expected : an error that states another machine is updating, and you do not get booted out of the account.
Actual : an error that states "wrong sync key" and home boots you out of the account

Note:
1. hard to reproduce

Comment 1

8 years ago
Not sure I'm following this. Did you set up a new account on your desktop and then immediately try to set up Home?

Also, it is not an error to have multiple clients updating at the same time. 

Please provide Firefox Sync version on desktop and Firefox Home version on iphone/ipod?
This could be a weird timing issue. Isn't it so that Before Home is able to sync, you will have to have synced with the desktop at least once. Otherwise the collections are not there. Maybe we should catch that corner case and show an appropriate message. Or simply retry a few moments later.

This is probably simple to reproduce on the python test server. I can do this.
I am guessing it's a timing issue with the read/write lock with a sync account that has a long list.

If you watch the sync-log on the desktop, it takes a while to sync 2000 webpages.
There is no read/write lock. I think what happens is that if the collections don't exist yet, Home freaks out and gives some unrelated error message.

We can handle this in a better way.
I see.  thanks for the info.

Updated

8 years ago
Flags: blocking-fx-home1.0.4+
Duplicate of this bug: 591522
Summary: Can get an error message of wrong sync key if another machine is updating the sync account while home is syncing → Confusing error messages when Desktop has not yet fully synced
Naoki, did this error happen after you had already done the first sync from the Desktop? Or did it happen during the initial sync? In other words: was there already data synced when you triggered this?
Naoki, one more question: did you happen to do a Reset Sync on the Desktop when you triggered this?

Comment 9

8 years ago
Naoki, any update on this?
Stefan: If I recall correctly, I did it when the data was already synced as well as on first load.
I am unable to reproduce this error.
Note to self : try to reproduce the error.
I think there's something wrong with the sync engine in Firefox.  There's nothing stating that it's trying to sync in the Synclogs when I try to sync.  Will need to talk to Tracy.
If you're using trunk nightlies, logging is off by default.
I haven't been able to reproduce the error today.  Marking as WFM for now.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.