XML Parsing Error when querying file:/// on directory with file like "test.ext&arg"

RESOLVED DUPLICATE of bug 525222

Status

()

Core
Networking: File
RESOLVED DUPLICATE of bug 525222
8 years ago
8 years ago

People

(Reporter: Vladimir Rutsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.10) Gecko/20100915 Ubuntu/10.04 (lucid) Firefox/3.6.10

Firefox fails to display contents of local directories (file:///) when they contains files like "test.ext&arg", please see Steps to Reproduce for details.

Reproducible: Always

Steps to Reproduce:
1. Create file with ampersand after dot in name, like "test.ext&arg":
 $ mkdir -p /tmp/dir_content
 $ touch '/tmp/dir_content/test.ext&arg'
2. Open directory with created file from Firefox: file:///tmp/dir_content/

Actual Results:  
Firefox displays error message:

XML Parsing Error: not well-formed
Location: file:///tmp/dir_content
Line Number 201, Column 109: <td sortable-data="2test.ext&amp;arg"><a class="file" href="test.ext&amp;arg"><img src="moz-icon://.ext&arg?size=16" alt="File:" />test.ext&amp;arg</a></td>
------------------------------------------------------------------------------------------------------------^


Expected Results:  
Firefox should display content of folder.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 525222
You need to log in before you can comment on or make changes to this bug.