The default bug view has changed. See this FAQ.

Importing a .cvf with empty lines doesn't work

RESOLVED FIXED in Thunderbird 15.0

Status

MailNews Core
Import
RESOLVED FIXED
7 years ago
5 years ago

People

(Reporter: Usul, Assigned: Leon Sha)

Tracking

Trunk
Thunderbird 15.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
In bug 600798 there are two vcard that are suposed to work with the code added in bug 79709. The first one works, the second one doesn't.

Files can be found at http://hg.mozilla.org/qa/litmus-data/file/947e21f848da/thunderbird/import the emptylines_vcard_addressbook.vcf is the faulty file.
(Reporter)

Updated

6 years ago
OS: Mac OS X → All
(Reporter)

Updated

6 years ago
Duplicate of this bug: 674841
(Assignee)

Comment 2

5 years ago
Created attachment 622993 [details] [diff] [review]
patch

Filter out the empty line.
Attachment #622993 - Flags: review?
(Assignee)

Updated

5 years ago
Attachment #622993 - Flags: review? → review?(dbienvenu)

Updated

5 years ago
Assignee: nobody → leon.sha
Status: NEW → ASSIGNED
Hardware: x86 → All

Comment 3

5 years ago
Comment on attachment 622993 [details] [diff] [review]
patch

you could instead use do while and pass in aMore directly to ReadLine, so the code would look like this:

do {
  rv = aLineStream->ReadLine(line, aMore);
}
while (line.IsEmpty() && *aMore);
if (!*aMore)
  return rv;
Attachment #622993 - Flags: review?(dbienvenu) → review+
(Assignee)

Comment 4

5 years ago
http://hg.mozilla.org/comm-central/rev/d8c08657b365
(Reporter)

Updated

5 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Target Milestone: --- → Thunderbird 15.0
You need to log in before you can comment on or make changes to this bug.