OS/2 - Printing a page with incomplete data causes crash

RESOLVED WORKSFORME

Status

()

P3
normal
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: barryma22, Assigned: mkaply)

Tracking

Trunk
x86
OS/2
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
OS/2 1114, WSeB, 770x, SDD, Faxworks Pro for OS/2 3 with all latest 
public fixes, clean install

I'm on dialup right now, so I can simulate a couple of things that 
don't happen in the broadband connected world.  You may have to find a 
really slow site to make these happen.

Making Warpzilla print while the page isn't finished loading caused a 
couple of TRAPs.

The first happened when I didn't get all the image data from slashdot.  
The console did say something about NSJPG.DLL load errors (2 as I 
recall).

11-16-2000  11:32:54  SYS3175  PID 003e  TID 0001  Slot 0079
C:\MOZILLA\BIN\MOZILLA.EXE
c0000005
000003c0
P1=00000001  P2=000003c0  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=024c0380  EBX=024bc8ac  ECX=0103c2b0  EDX=00000005
ESI=0103e07c  EDI=00000000  
DS=0053  DSACC=d0f3  DSLIM=3fffffff  
ES=0053  ESACC=d0f3  ESLIM=3fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:000003c0  CSACC=d0df  CSLIM=3fffffff
SS:ESP=0053:0103c25c  SSACC=d0f3  SSLIM=3fffffff
EBP=0103c430  FLG=00012206

------------------------------------------------------------



The next TRAP occured when I was trying to print a page while the data 
was still coming down.  Warpzilla let me have control back, so off to 
printer with what I had...  and then you get...

------------------------------------------------------------

11-16-2000  11:34:44  SYS3175  PID 0049  TID 0001  Slot 0079
C:\MOZILLA\BIN\MOZILLA.EXE
c0000005
15c0cca5
P1=00000001  P2=000001b4  P3=XXXXXXXX  P4=XXXXXXXX  
EAX=01c4a10c  EBX=00000000  ECX=0103d5d8  EDX=01a857e0
ESI=0103de64  EDI=00000000  
DS=0053  DSACC=d0f3  DSLIM=3fffffff  
ES=0053  ESACC=d0f3  ESLIM=3fffffff  
FS=150b  FSACC=00f3  FSLIM=00000030
GS=0000  GSACC=****  GSLIM=********
CS:EIP=005b:15c0cca5  CSACC=d0df  CSLIM=3fffffff
SS:ESP=0053:0103d5c0  SSACC=d0f3  SSLIM=3fffffff
EBP=0103d5e8  FLG=00212206

NGLAYOUT.DLL 0001:000bcca5

Comment 1

18 years ago
Is this still a problem in the latest nightlies?

Comment 2

18 years ago
Marking WORKSFORME due to lack of response. Reopen if its still a problem in the
latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.