browser freezes while escaping awesome bar during first sync

RESOLVED DUPLICATE of bug 570619

Status

Cloud Services
General
RESOLVED DUPLICATE of bug 570619
8 years ago
8 years ago

People

(Reporter: juanb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
On a brand new machine with a build from 10/08, I set up Minefield with my existing account, and I started typing for an entry I know exists in my history, but it didn't find it. I waited a few seconds and I tried again, this time it came up, with a bunch of tagged bookmarks except the item I was looking for so I tried ESC. The browser froze for about 10 seconds.

During this time I would hover over the taskbar and there were several blank thumbnails, more thumbnails than open tabs in the browser before it froze. Perhaps in desperation during the freeze I had tried a few ctrl-t's.

After it came back, the thing I was looking for showed on top.

It would be nice if this first experience was freeze free.
First sync generates the RSA keypair and generally does a lot of work, all of it on the main thread. Moving crypto off the main thread (bug 570619) will solve much of this.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 570619
You need to log in before you can comment on or make changes to this bug.