Closed Bug 603415 Opened 11 years ago Closed 11 years ago

controls missing if overflow: auto; and border-top-left-radius is set

Categories

(SeaMonkey :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 595842

People

(Reporter: iav, Unassigned)

Details

Attachments

(2 files, 2 obsolete files)

controls missing if overflow: auto; and border-top-left-radius is set
Attached file test case (obsolete) —
All on trunk, Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre SeaMonkey/2.1b2pre
Attached file test case (obsolete) —
now passes w3c xhtml validation
Attachment #482298 - Attachment is obsolete: true
Attached file test case
Attachment #482310 - Attachment is obsolete: true
See the same for firefox trunk Mozilla/5.0 (Windows NT 5.1; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre
but firefox 20101011 doesn't
Bisect give me
Due to skipped revisions, the first bad revision could be any of:
changeset:   52297:c1cc7b565dc7
user:        Zack Weinberg <zweinberg@mozilla.com>, L. David Baron <dbaron@dbaron.org>
date:        Thu Sep 09 08:21:47 2010 -0700
summary:     Bug 451134 (1/2): switch to the official border-radius property names: purely mechanical changes.  r=dbaron  a2.0=blocking2.0:beta6

changeset:   52298:c954983caff1
user:        Zack Weinberg <zweinberg@mozilla.com>
date:        Thu Sep 09 08:21:48 2010 -0700
summary:     Bug 451134 (2/2): switch to the official border-radius property names: by-hand changes.  r=dbaron  a2.0=blocking2.0:beta6

changeset:   52299:8adb2f64c138
user:        L. David Baron <dbaron@dbaron.org>
date:        Thu Sep 09 08:21:48 2010 -0700
summary:     Add aliases for old names of border-radius properties.  (Bug 451134)  r=bzbarsky  a2.0=blocking2.0:beta6

[command completed successfully Wed Oct 13 03:27:09 2010]
Before the changes you found with bisect, Firefox (and Seamonkey too, I would think) would have been ignoring your border-top-left-radius specification entirely.  Could you change your test case so the style rule reads

#content {
    overflow: auto;
    border-top-left-radius: 10px;
    -moz-border-radius-topleft: 10px;
}

and repeat the bisect?  That will find the actual regression point.
Is that the same issue as bug 595842?
Possible.
Bisect for a new testcase is running now. Will compare results with same from first post of bug 595842.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595842
You'll get almost the same results for the bisect, since the patch for rounded clipping of overflow!=visible landed very close to the renaming.  But I don't think it's worth the bother; this is a known bug.
You need to log in before you can comment on or make changes to this bug.