If no tabs are sync'd, integrated Sync UI should not show device name

VERIFIED FIXED

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: tchung, Assigned: fabrice)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 482416 [details]
No Tabs in Desktop Screenshot

The device name is appearing in the Integrated Sync UI even though there are no tabs that are sync'd in that account.   We should hide these accounts from the Desktop View in these situations.

See screenshot.  "suckahhhh" is an account on another device with no open tabs

Repro:
1) install fennec nightly on maemo and android: 
Mozilla/5.0 (Maemo; Linux armv71; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre Fennec/4.0b2pre	
or 
Mozilla/5.0 (Android; Linux armv71; rv:2.0b8pre) Gecko/20101011 Firefox/4.0b8pre Fennec/4.0b2pre	
2) Sync an account with no tabs 
3) Open account on a fennec device, and click tabs from other computers or Desktop from awesomescreen
4) Verify the Sync'd account with no tabs open displays the Device name, but no tabs

Expected:
- if the sync account has no open tabs, then we should not display the device at all in the Desktop view

ActuaL:
- see screenshot.  device name is present in the list
(Reporter)

Updated

7 years ago
Blocks: 599500
No longer depends on: 599500
tracking-fennec: --- → 2.0+

Comment 1

7 years ago
Madhava, what do you want us to do here?
I thought there was another bug (a dupe of this) somewhere. We decided to just hide computers that have no open tabs, which can happen with old, unused computers or devices.

Sync has no way yet to drop those devices from your account.
(Assignee)

Comment 3

7 years ago
Created attachment 502963 [details] [diff] [review]
patch
Assignee: nobody → fabrice
Attachment #502963 - Flags: review?(mark.finkle)
Attachment #502963 - Flags: review?(mark.finkle) → review+
Keywords: checkin-needed
Fabrice - you can land stuff now, right? :)
(Assignee)

Comment 5

7 years ago
Pushed :
http://hg.mozilla.org/mobile-browser/rev/8e32f711ac82
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED

Comment 6

7 years ago
VERIFIED FIXED on:

Build ID Central: 
Mozilla /5.0 (Android;Linux armv7l;rv:6.0a1) Gecko/20110513 Firefox/6.0a1 Fennec/6.0a1  

Build ID Aurora:
Mozilla /5.0 (Android;Linux armv7l;rv:5.0a1) Gecko/20110512 Firefox/5.0a2 Fennec/5.0a2 

Device : HTC Desire Z (Android 2.2)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.