Avoid GC slowdown running SunSpider in the browser

RESOLVED DUPLICATE of bug 598650

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 598650
8 years ago
8 years ago

People

(Reporter: dmandelin, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
We seem to spend a variable 5-20 ms GCing while running SunSpider in the browser. More precisely, when I run SunSpider it seems that GC makes the final score worse by about that amount. This is one of the biggest slowdowns w.r.t. the competition that we still have on SunSpider.
(Reporter)

Updated

8 years ago
Depends on: 603529

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598650

Updated

8 years ago
No longer depends on: 603529
You need to log in before you can comment on or make changes to this bug.