Test failure in testUndoTabFromContextMenu.js | testTabbedBrowsingAPI (default)

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: aaronmt, Assigned: aaronmt)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lib][mozmill-test-failure][needs-mozmill-1.5.1], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Assignee)

Description

8 years ago
MODULES: firefox/testSessionStore/testUndoTabFromContextMenu.js
TEST: testUndoTabFromContextMenu.js
ERROR: Controller.assertJSProperty(ID: context_undoCloseTab) : true == false
BRANCH: default

We seem to be opening navigation bar context menu when we want to be opening the tab bar context menu. Changing the targeted element to 'tabs_strip' still produces this issue.

Side note: The assert should also be changed to assertDOMProperty.
That's exactly the bug Jeff is catching with in the last day on a box beside his desktop. Interesting that it now also appears on brasstacks. It still works fine locally. So this is getting more interesting.

(In reply to comment #0)
> Side note: The assert should also be changed to assertDOMProperty.

No, there is no disabled property attached to the DOM. It's a property of the JS object. And instead of the strip we should also right click the first tab. The strip itself will not show the tab context menu.

Comment 2

8 years ago
(In reply to comment #0)
> MODULES: firefox/testSessionStore/testUndoTabFromContextMenu.js
> TEST: testUndoTabFromContextMenu.js
> ERROR: Controller.assertJSProperty(ID: context_undoCloseTab) : true == false
> BRANCH: default
> 
> We seem to be opening navigation bar context menu when we want to be opening
> the tab bar context menu. Changing the targeted element to 'tabs_strip' still
> produces this issue.
> 
> Side note: The assert should also be changed to assertDOMProperty.

I saw this on OS X 32 bit.   Is this where you see it as well?
On brasstacks it's happening on Windows and Linux too. Aaron, if you can reproduce it would be great if you could provide a patch. That failure blocks us from getting the tests into buildbot. If you can't please tell me and I will check the test on qa-horus itself.
(Assignee)

Updated

8 years ago
Keywords: regression
(Assignee)

Comment 4

8 years ago
Am able to reproduce on OSX and Linux, have not tried Windows. 

Assuming the replace of getElement with getTab, the nav toolbar still opens instead. |var tabBar = tabBrowser.getTab(0);|
(Assignee)

Comment 5

8 years ago
The above works with tabs on bottom. I think it's just a targeting issue the position where we are clicking.
(Assignee)

Comment 6

8 years ago
This same regression is also hurting testCloseTab.js and testNewTab.js as both work with tabs on bottom.
Can you test with my patch from the events branch:
http://github.com/whimboo/mozmill/commits/events

I wonder if this will fix this problem.
It probably will because the rounded corners will not be the problem anymore. Remember those are at the top left for tabs on top. When we click at (2,2) we end up outside of the tab.
(Assignee)

Comment 9

8 years ago
Yep, your events branch fixes this issue when I change the element we want to click on to getTab at its index. As well, your events branch fixes the tabbedBrowsing tests.

I'll post a patch for this test in a minute.
(Assignee)

Comment 10

8 years ago
Created attachment 482610 [details] [diff] [review]
Patch v1 - (default)

This patch and test will pass once 1.5.1 is released with your events patch.
Assignee: nobody → aaron.train
Status: NEW → ASSIGNED
Attachment #482610 - Flags: review?(hskupin)
(Assignee)

Updated

8 years ago
Depends on: 583604
(Assignee)

Comment 11

8 years ago
Created attachment 482624 [details] [diff] [review]
Patch v1 - (default)

Default to the selectedIndex in getTab()
Attachment #482610 - Attachment is obsolete: true
Attachment #482624 - Flags: review?(hskupin)
Attachment #482610 - Flags: review?(hskupin)
Comment on attachment 482624 [details] [diff] [review]
Patch v1 - (default)

Makes absolutely sense. Does this patch apply cleanly for older branches?
Attachment #482624 - Flags: review?(hskupin) → review+
Summary: [shared module] Test failure in testUndoTabFromContextMenu.js | testTabbedBrowsingAPI (default) → Test failure in testUndoTabFromContextMenu.js | testTabbedBrowsingAPI (default)
Whiteboard: [mozmill-test-failure] → [mozmill-test-failure][shared module]
(Assignee)

Comment 14

8 years ago
Created attachment 482656 [details] [diff] [review]
Patch v1 - (1.9.2 & 1.9.1)

1.9.2 and 1.9.1
Comment on attachment 482656 [details] [diff] [review]
Patch v1 - (1.9.2 & 1.9.1)

Landed backport:
http://hg.mozilla.org/qa/mozmill-tests/rev/b46cf069ad7d (mozilla1.9.2)
http://hg.mozilla.org/qa/mozmill-tests/rev/43b12508e3b8 (mozilla1.9.1)

I will leave this bug open until the dependencies have been fixed.
Attachment #482656 - Flags: review?(hskupin) → review+
(Assignee)

Updated

8 years ago
Whiteboard: [mozmill-test-failure][shared module] → [mozmill-test-failure][shared module][needs-mozmill-1.5.1]
Move of Mozmill Test related project bugs to newly created components. You can
filter out those emails by using "Mozmill-Tests-to-MozillaQA" as criteria.
Component: Mozmill Tests → Mozmill Tests
Product: Testing → Mozilla QA
Version: Trunk → unspecified
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Component: Mozmill Tests → Mozmill Shared Modules
Component: Mozmill Shared Modules → Mozmill Tests
Whiteboard: [mozmill-test-failure][shared module][needs-mozmill-1.5.1] → [lib]
Whiteboard: [lib] → [lib][mozmill-test-failure][needs-mozmill-1.5.1]
You need to log in before you can comment on or make changes to this bug.