command-L when link is hovered draws highlight bar without URL text

RESOLVED FIXED in Firefox 4.0b8

Status

()

defect
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: sayrer, Unassigned)

Tracking

Trunk
Firefox 4.0b8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
I had noticed that this transition looked a little wonky, but I wasn't quite sure what was wrong. I've caught it a couple times in really bad ways in the past few days. The first time, I was running under valgrind (read: slow) and I saw it occur in slow motion. Later on, I managed to get my fast macbook wedged in this state for 5 seconds or so while waking up from sleep.

Here is a slow motion rendition:

http://www.youtube.com/watch?v=sNF_qoJkI_E

I get a blue highlight bar with no text drawn. At realtime speed, it just looks jittery and broken.
(Reporter)

Comment 1

9 years ago
I'm pretty sure what is happening here is that the URL focused by command-L is supposed fade in while the hover text fades out. However, there's an interim state where the focused URL has not yet faded in, but the text highlight is drawn. This leaves an empty blue rectangle in my screencast. I think this state lasts rather longer than we would like on actual computers.
Blocks: 587908
Component: Tabbed Browser → Location Bar
QA Contact: tabbed.browser → location.bar
Yeah, this is a problem.  The patch in bug 597581 fixes this.  Hopefully Dao will review it soon...

Requesting blocking (final) because we shouldn't ship Firefox 4 like this.
blocking2.0: --- → ?
OS: Mac OS X → All
Hardware: x86 → All
Fixed by bug 597581.  Cmd+L while a link target is shown causes the link target to disappear immediately and the current URL to appear immediately.
Status: NEW → RESOLVED
blocking2.0: ? → ---
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b8
You need to log in before you can comment on or make changes to this bug.