Problem when copying information between tabs

RESOLVED DUPLICATE of bug 616843

Status

()

Firefox
Tabbed Browser
RESOLVED DUPLICATE of bug 616843
7 years ago
3 years ago

People

(Reporter: System Error, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10

When i open a pop-up window with Authentication (username and password) i can not switch to any other tab to copy the needed information. This is very useful when you have a lot of passwords and etc. and you have to type it manually or use IE (there is no problem when i copy between tabs in internet explorer - the other tabs are active when authentication window is open).

Reproducible: Always

Steps to Reproduce:
1.open a 2 tabs on the first is the info i have to copy the second is for example a secured site or a router login page.
2. when i open the tab with the login and the pop up window is open i can not switch to any other tab.
3. i have to copy the info to text editor and then to the authentication window
Actual Results:  
i can not copy between tabs

Expected Results:  
when a pop-up window for authentication is opened i want to swtich between all other tabs i`ve opened before this.

If you want see this bug try this :
1. Open 2 tabs.
2.  In the second tab open this site : http://download.eset.com/download/win/eav/eav_nt32_enu.msi (it is anti virus ) then try to open the first tab. You wont be able to do it. :)
Whiteboard: dupeme
I think this is just the nature of modal dialogs. You need to dismiss the dialog before you are able to interact with any tabs again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> I think this is just the nature of modal dialogs. You need to dismiss the
> dialog before you are able to interact with any tabs again.

But why do i have to close the dialog ? I have to copy info in it.  Alternative browsers don`t have this bug.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

7 years ago
Depends on: 562258

Updated

7 years ago
Depends on: 59314
No longer depends on: 562258

Comment 3

7 years ago
All this bug is saying is that modal dialogs that are tab-specific should be tab-modal to enable copying information from _another_ tab.

Duping it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 616843

Updated

4 years ago
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.