Closed Bug 60393 Opened 21 years ago Closed 21 years ago

Should prevent users select same folder when move/copy messages

Categories

(SeaMonkey :: MailNews: Message Display, defect, P3)

x86
Windows NT
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 16717

People

(Reporter: huang, Assigned: scottputterman)

Details

Used 11-16-08-Mtrunk build

NMS/AOL/Webmail/UW IMAP - Should prevent users select INBOX folder when
move/copy messages

Overview: There are some IMAP server won't allow to create subfolders under the
INBOX, so on the Message menu -- should disable INBOX from the copy and Move
Message menu item to prevent users selecting INBOX folder for copying messages

1) Login to any IMAP account list from above servers
2) Select the Inbox imcoming messages
3) Select Message|Move(or Copy Message)|Server name|Inbox
4) Actual Results: The Inbox is available from the folder list which is not
correct

Expected Results: The Inbox should be disable to prevent users select INBOX
folder when move/copy messages for those specific IMAP servers
QA Contact: esther → huang
Removing NMS/AOL/Webmail/UW and Inbox since this bug should apply to all IMAP 
servers and all the folders. After users select the messages from the thread 
pane to move or copy, if the destination is the the same folder, it should grey 
out(disable) since you cannot move/copy messages to the same folder.

Additional Info:  From 4.x - 
 - When select "Message|Move message" to the same folder will grey out for that 
folder.
 - When select "Message|Copy message" to the same folder won't grey out for that 
folder, but display an Caution message: "Can't move or copy messages to the 
folder they're already in."

I don't know why it will be disable for Move, but not for Copy in 4.x?? This is 
just FYI.
Summary: NMS/AOL/Webmail/UW IMAP - Should prevent users select INBOX folder when move/copy messages → Should prevent users select same folder when move/copy messages

*** This bug has been marked as a duplicate of 16717 ***
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → DUPLICATE
Verified as dup.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.