Last Comment Bug 604175 - ignoring of invalid at-keywords (@-keywords) should stop at end of containing block ({})
: ignoring of invalid at-keywords (@-keywords) should stop at end of containing...
Status: RESOLVED FIXED
: css2
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla5
Assigned To: Nobody; OK to take it and work on it
:
: Jet Villegas (:jet)
Mentors:
http://test.csswg.org/suites/css2.1/2...
Depends on:
Blocks: css2.1-tests
  Show dependency treegraph
 
Reported: 2010-10-13 14:25 PDT by David Baron :dbaron: ⌚️UTC-10
Modified: 2011-03-23 13:46 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (7.92 KB, patch)
2011-01-25 11:30 PST, David Baron :dbaron: ⌚️UTC-10
no flags Details | Diff | Splinter Review
patch (7.96 KB, patch)
2011-01-25 11:32 PST, David Baron :dbaron: ⌚️UTC-10
bzbarsky: review+
Details | Diff | Splinter Review

Description David Baron :dbaron: ⌚️UTC-10 2010-10-13 14:25:28 PDT
http://test.csswg.org/suites/css2.1/20100917/xhtml1/at-rule-013.xht fails because we haven't implemented the new rule in CSS 2.1 regarding ignoring of invalid at-keywords:

# User agents must ignore an invalid at-keyword together with everything
# following it, up to the end of the block that contains the invalid at-keyword,
# or up to and including the next semicolon (;), or up to and including the next
# block ({...}), whichever comes first.

We incorrectly continue past the end of the block that contains the invalid at-keyword.
Comment 1 Tantek Çelik 2011-01-25 11:21:40 PST
(citation)

The # quoted text above (User agents must ignore...) is from the list item that starts with "At-rules with unknown at-keywords." in section "4.2 Rules for handling parsing errors" in CSS 2.1: http://www.w3.org/Style/css2-updates/css2/syndata.html#parsing-errors
Comment 2 David Baron :dbaron: ⌚️UTC-10 2011-01-25 11:30:27 PST
Created attachment 506827 [details] [diff] [review]
patch
Comment 3 David Baron :dbaron: ⌚️UTC-10 2011-01-25 11:32:51 PST
Created attachment 506828 [details] [diff] [review]
patch

oops, forgot to update patch description
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2011-01-25 11:37:27 PST
Comment on attachment 506828 [details] [diff] [review]
patch

r=me
Comment 5 David Baron :dbaron: ⌚️UTC-10 2011-03-03 19:04:30 PST
https://hg.mozilla.org/projects/birch/rev/b6a3ab183a8f
Comment 6 David Baron :dbaron: ⌚️UTC-10 2011-03-23 13:46:39 PDT
https://hg.mozilla.org/mozilla-central/rev/b6a3ab183a8f

Note You need to log in before you can comment on or make changes to this bug.