After installing a persona, going in and out of Full screen mode, does not restore the window properly

RESOLVED FIXED

Status

()

Core
Widget: Win32
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: aravindm, Assigned: jimm)

Tracking

({regression})

unspecified
x86
Windows 7
regression
Points:
---

Firefox Tracking Flags

(blocking2.0 final+)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre

Steps to reproduce :
1. Install a new persona
2. Go to Full screen mode (F11)
3. Exit Full screen mode(F11)

Actual results :
Window is not restored properly after going in and out of full screen mode. Hovering on the navigational bar and menu bar displays the items.

Expected results : 
Window should be restored normally without any glitches. 

Screencash of the issue : 
http://screencast-o-matic.com/create?step=info&sid=1287047544&itype=choose
(Reporter)

Comment 1

7 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101013 Firefox/4.0b8pre

Able to reproduce in the latest build also.
(Reporter)

Comment 2

7 years ago
Sorry, actually tested in 
Mozilla/5.0 (Windows NT 6.1; rv:2.0b7pre) Gecko/20101006 Firefox/4.0b7pre
(In reply to comment #0)
> http://screencast-o-matic.com/create?step=info&sid=1287047544&itype=choose

Apparently this requires installing a plug-in. Would you mind attaching a screenshot?
(Reporter)

Comment 4

7 years ago
Created attachment 483135 [details]
After installing a persona, Window is not restored after exiting full screen mode

Updated

7 years ago
Component: Theme → Graphics
Product: Firefox → Core
QA Contact: theme → thebes

Updated

7 years ago
blocking2.0: --- → ?
I'm almost certain we have a bug like this already. We probably can't release with this bug regardless, though.
blocking2.0: ? → final+
Component: Graphics → Widget: Win32
QA Contact: thebes → win32
Whiteboard: DUPEME
Assignee: nobody → jmathies
(Assignee)

Comment 6

7 years ago
Hmm, not able to reproduce using a nightly. Win7 with aero enabled.

1) opened normal browser window
2) went to getpersonas.com
3) selected "wear it" on any persona on the home page
4) hit f11 
5) hit f11 again

everything is fine. Tried it with d2d enabled and disabled.
(Assignee)

Comment 7

7 years ago
felipe, curious if you can reproduce this?
I reproduced, the menu bar must be on (custom titlebar off).

Seems like an invalidation problem, the toolbars are there but haven't been rendered.
(Assignee)

Comment 9

7 years ago
(In reply to comment #8)
> I reproduced, the menu bar must be on (custom titlebar off).
> 
> Seems like an invalidation problem, the toolbars are there but haven't been
> rendered.

yep, ok, I see it now. thx.
(Assignee)

Updated

7 years ago
Whiteboard: DUPEME
(Assignee)

Comment 10

7 years ago
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0caec4ddff74&tochange=f38ef1080bfe

Likely cause: Bug 575855 - Fix for transitions from fullscreen briefly show an aero basic window frame.
Keywords: regression
(Assignee)

Comment 11

7 years ago
Created attachment 483506 [details] [diff] [review]
fix
Attachment #483506 - Flags: review?(vladimir)
Attachment #483506 - Flags: review?(vladimir) → review+
(Assignee)

Comment 12

7 years ago
http://hg.mozilla.org/mozilla-central/rev/e226f886e301
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Duplicate of this bug: 597939

Comment 14

7 years ago
hi Jim, tested here, works perfectly
Duplicate of this bug: 617890
You need to log in before you can comment on or make changes to this bug.