crash [@ xpc::CrossOriginAccessiblePropertiesOnly::check(JSContext*, JSObject*, int, JSWrapper::Action, JSWrapper::Permission&) ]

RESOLVED DUPLICATE of bug 604368

Status

()

Core
XPConnect
--
critical
RESOLVED DUPLICATE of bug 604368
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

(crash signature)

(Reporter)

Description

7 years ago
Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101014
Firefox/4.0b8pre

This is a new crash signature. Crashes first appeared in b8pre/20101011 build.
It is #111 top crasher in 4.0b8pre for the last week.

Signature	xpc::CrossOriginAccessiblePropertiesOnly::check(JSContext*, JSObject*, int, JSWrapper::Action, JSWrapper::Permission&)
UUID	2ce3eb6f-be62-447d-80b5-7b97c2101014
Time 	2010-10-14 07:27:08.975013
Uptime	224
Last Crash	2391462 seconds (4.0 weeks) before submission
Install Age	11344 seconds (3.2 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101013225426
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 8 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0xc020214
App Notes 	AdapterVendorID: 10de, AdapterDeviceID: 0110

Frame 	Module 	Signature [Expand] 	Source
0 		@0x20027 	
1 	xul.dll 	xpc::CrossOriginAccessiblePropertiesOnly::check 	js/src/xpconnect/wrappers/AccessCheck.h:99
2 	xul.dll 	xpc::CheckAndReport<xpc::CrossOriginAccessiblePropertiesOnly> 	js/src/xpconnect/wrappers/FilteringWrapper.cpp:89
3 	xul.dll 	xpc::FilteringWrapper<xpc::XrayWrapper<JSCrossCompartmentWrapper,xpc::CrossCompartmentXray>,xpc::CrossOriginAccessiblePropertiesOnly>::enter 	js/src/xpconnect/wrappers/FilteringWrapper.cpp:149
4 	mozjs.dll 	JSWrapper::has 	js/src/jswrapper.cpp:192
5 	mozjs.dll 	JSCrossCompartmentWrapper::has 	js/src/jswrapper.cpp:462
6 	mozjs.dll 	js::JSProxy::has 	js/src/jsproxy.cpp:760
7 	mozjs.dll 	js::proxy_LookupProperty 	js/src/jsproxy.cpp:837
8 	mozjs.dll 	mozjs.dll@0x890bf 	
9 	mozjs.dll 	with_LookupProperty 	js/src/jsobj.cpp:3043
10 	mozjs.dll 	js_FindPropertyHelper 	js/src/jsobj.cpp:4794
11 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4819
12 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
13 	mozjs.dll 	js::Execute 	js/src/jsinterp.cpp:998
14 	mozjs.dll 	JS_EvaluateUCScriptForPrincipals 	js/src/jsapi.cpp:4882
15 	xul.dll 	xpc_EvalInSandbox 	js/src/xpconnect/src/xpccomponents.cpp:3661
16 	xul.dll 	nsXPCComponents_Utils::EvalInSandbox 	js/src/xpconnect/src/xpccomponents.cpp:3551
17 	xul.dll 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp:102
18 	xul.dll 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1631
19 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4714
20 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
21 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:747
22 	mozjs.dll 	js_fun_call 	js/src/jsfun.cpp:2248
23 	mozjs.dll 	js::Interpret 	js/src/jsinterp.cpp:4714
24 	mozjs.dll 	js::RunScript 	js/src/jsinterp.cpp:638
25 	mozjs.dll 	js::Invoke 	js/src/jsinterp.cpp:747
26 	mozjs.dll 	js::ExternalInvoke 	js/src/jsinterp.cpp:871
27 	mozjs.dll 	JS_CallFunctionValue 	js/src/jsapi.cpp:4961
28 	xul.dll 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1692
29 	xul.dll 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:571
30 	xul.dll 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:114
31 	xul.dll 	SharedStub 	xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp:141
32 	xul.dll 	nsObserverList::NotifyObservers 	xpcom/ds/nsObserverList.cpp:130

The regression range is :
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=26c47ba8064f&tochange=5a41a70eb631

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&query_search=signature&query_type=exact&query=&range_value=4&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=xpc%3A%3ACrossOriginAccessiblePropertiesOnly%3A%3Acheck%28JSContext*%2C%20JSObject*%2C%20int%2C%20JSWrapper%3A%3AAction%2C%20JSWrapper%3A%3APermission%26%29
blocking2.0: --- → ?

Updated

7 years ago
blocking2.0: ? → beta7+

Comment 1

7 years ago
with_LookupProperty ... lovely. with around a wrapper.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 604368
(Assignee)

Updated

7 years ago
Crash Signature: [@ xpc::CrossOriginAccessiblePropertiesOnly::check(JSContext*, JSObject*, int, JSWrapper::Action, JSWrapper::Permission&) ]
You need to log in before you can comment on or make changes to this bug.