Closed Bug 604392 Opened 11 years ago Closed 11 years ago

WebGL is no longer enabled on Windows x86_64

Categories

(Core :: Canvas: WebGL, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: scoobidiver, Unassigned)

Details

(Keywords: regression)

Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101014 Firefox/4.0b8pre

From b8pre/20101013 build, WebGL is no more enabled.

The regression range is :
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=2593c8c8af8b&tochange=f6e81dd5a125

Graphic data :
Adapter Description: Mobile Intel(R) 4 Series Express Chipset Family
Vendor ID: 8086
Device ID: 2a42
Adapter RAM: Unknown
Adapter Drivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
Driver Version: 8.15.10.2202
Driver Date: 8-25-2010
Direct2D Enabled: true
DirectWrite Enabled: true
GPU Accelerated Windows: 1/1 Direct3D 10
This is mysterious to me, I'm looking at the GfxInfo.cpp code and I can't understand why it's not enabled for you. Also, looking at the commits in this revision range I don't see any big suspect. I'll try simulating your config in the blocklist...
Summary: WebGL is no more enabled → WebGL is no longer enabled
In bug 604771, there is now a patch to spoof GfxInfo (it also allows circumventing the blocklist).

I have spoofed as your config, and WebGL is still enabled for me.

So this is not a GfxInfo bug.

I am now turning my attention to bug 604395 's suggestion that it might be caused by changeset 085538a08eb2. (A confirmation of that would be useful).
I have the same error as in bug 604395 comment 8.

This bug and bug 604395 seems to be related to 64-bit OS. Can it be the same issue ?
Summary: WebGL is no longer enabled → WebGL is no longer enabled on Windows x86_64
Here on both linux 64 (firefox 64) and windows 64 (firefox 32), I can't reproduce the problem.
It works in 4.0b8pre/20101102 build.
So I close this bug.
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Most probably it was a dupe of bug 604395, which indeed turned out to be a general OpenGL initialization bug on all platforms, and was fixed on Monday.
Resolution: WORKSFORME → FIXED
You need to log in before you can comment on or make changes to this bug.