Command Completion broken on today's build in JSTerm

RESOLVED FIXED in Firefox 4.0b7

Status

()

Firefox
Developer Tools
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: rc, Assigned: ddahl)

Tracking

({regression})

unspecified
Firefox 4.0b7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 beta7+)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Web Console's JSTerm is no longer completing entries.

today's build: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre)
Gecko/20101014 Firefox/4.0b8pre
built from:
http://hg.mozilla.org/mozilla-central/rev/ad0a0be8be74
(Reporter)

Comment 1

7 years ago
requesting blocking
blocking2.0: --- → ?
Keywords: regression
(Assignee)

Comment 2

7 years ago
I'm seeing this:

Error: uncaught exception: [Exception... "Component is not available"  nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)"  location: "JS frame :: resource:///modules/HUDService.jsm :: JSPropertyProvider :: line 3878"  data: no]

Error: obj.__lookupGetter__ is not a function
Source File: resource:///modules/HUDService.jsm
Line: 3861

Updated

7 years ago
Blocks: 594225
(Assignee)

Comment 3

7 years ago
We did not know this happend via our tests due to this changeset:

http://hg.mozilla.org/mozilla-central/rev/29c228a4d7eb
(Reporter)

Comment 4

7 years ago
was there a bug added to re-enable them anywhere? Johnny, help us out here.
blocking2.0: ? → beta7+

Comment 5

7 years ago
ddahl has a fix to this which he has said is a "one-liner". The fix is apparently visible in another patch:

https://bugzilla.mozilla.org/show_bug.cgi?id=587734#c60

but ddahl will break that out to land it for beta 7.
Assignee: nobody → ddahl

Updated

7 years ago
Blocks: 593957
No longer blocks: 594225
(Assignee)

Comment 6

7 years ago
I am attaching a patch momentarily
(Assignee)

Comment 7

7 years ago
Created attachment 484027 [details] [diff] [review]
v 0.1 Fix tab-completion

one liner that fixes tab completion
Attachment #484027 - Flags: review?(sdwilsh)
(Reporter)

Updated

7 years ago
Blocks: 604536
(Reporter)

Comment 8

7 years ago
this fix clears the errors from the disabled tests in bug 604536. Feedback+++++ from me.
Attachment #484027 - Flags: review?(sdwilsh) → review+
(Assignee)

Comment 9

7 years ago
http://hg.mozilla.org/mozilla-central/rev/a191d97b0192
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 4.0b7
You need to log in before you can comment on or make changes to this bug.