Undo closed tab shows no page title in title bar

RESOLVED DUPLICATE of bug 598221

Status

()

RESOLVED DUPLICATE of bug 598221
8 years ago
8 years ago

People

(Reporter: davemgarrett, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
With 2 or more tabs open, close one then undo the close. At start the tab's title was in the window's title bar. On undo it's simply "Minefield" and no title. Switch to another tab and back and it will show correctly. Same effect using keyboard shortcuts or close button and menu. Can be tested with the initial two tabs of a new profile or any tabs thereafter.

Tested on Kubuntu 10.04 and Windows XP SP3.
(Reporter)

Comment 1

8 years ago
Beta 6 works fine, so it regressed sometime after that. (bit of a big window)

Comment 2

8 years ago
Maybe duplication of Bug 598221 - Page Title not shown in Title Bar on Session Restore
(Reporter)

Comment 3

8 years ago
Just went through some old nightlies and got a regression range. First failure is on 20100918. Pushlog between those builds:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=268ef4ccb5ff&tochange=fc8d8dfee20f

That's the same time as the regression range for bug 598221, so this looks like a subset of that bug seeing as undo is a single tab restore. Duping then.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 598221
You need to log in before you can comment on or make changes to this bug.