AeroPeek in Taskbar Previews show wrong title - always 'Minefield'

RESOLVED FIXED

Status

()

Firefox
Session Restore
--
major
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: Jim Jeffery not reading bug-mail 1/2/11, Unassigned)

Tracking

({regression})

Trunk
x86
Windows 7
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

Comment hidden (empty)
Open Minefield with 10 or less tabs and then once tabs are loaded mouse over the Taskbar Icon in Win7 and note that most of the tabs are incorrectly titled as 'Minefield'  Some will show the correct name, but most won't.  Selecting the tab will 'update' the name being displayed in the Aero-peek tab in the Taskbar.  

Regressed: 
K:\Moz2\20100923055721 36a9ff4549cc ok
K:\Moz2\20100924040732 9549708d2e90 bad

patch list:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2010-09-24+03%3A00%3A00&enddate=2010-09-25+04%3A00%3A00

Maybe caused by: 
https://bugzilla.mozilla.org/show_bug.cgi?id=598020 ?
Keywords: regression
blocking2.0: --- → ?

Updated

8 years ago
Duplicate of this bug: 604552

Comment 3

8 years ago
attachment 483354 [details] displays the problem.
I did an hg bisect and this seems to be a regression form bug 597673.  Evidently however this was working before must have been somehow dependent on the update icon code.
Blocks: 597673
Bug 597673 might have revealed it since updateIcon spawned an TabAttrModified event, but in the end this is just bug 598221, i.e. this code isn't getting TabAttrModified for the updated tab label.
Blocks: 586068
No longer blocks: 597673
Depends on: 598221
Fixed by landing of bug 598221

Tested using hourly build with cset:
http://hg.mozilla.org/mozilla-central/rev/afd457942f0d
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Posthumous blocking+ so it gets on the radar if re-opened.
blocking2.0: ? → final+
You need to log in before you can comment on or make changes to this bug.