Last Comment Bug 604673 - <output> should be subject for constraint validation
: <output> should be subject for constraint validation
Status: RESOLVED FIXED
[good first bug]
: dev-doc-complete, html5
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla2.0b8
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on: 613113
Blocks: html5forms
  Show dependency treegraph
 
Reported: 2010-10-15 09:15 PDT by Mounir Lamouri (:mounir)
Modified: 2010-11-19 09:27 PST (History)
5 users (show)
mounir: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (10.27 KB, patch)
2010-10-18 13:57 PDT, Mounir Lamouri (:mounir)
bugs: review+
limi: ui‑review+
benjamin: approval2.0+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2010-10-15 09:15:42 PDT
We are currently following the specifications but that seems to be wrong. It would be nice to have .setCustomValidity() working with <output>.
Comment 1 Mounir Lamouri (:mounir) 2010-10-15 09:15:55 PDT
W3C bug: http://www.w3.org/Bugs/Public/show_bug.cgi?id=10912
Comment 2 Mounir Lamouri (:mounir) 2010-10-18 13:57:49 PDT
Created attachment 484085 [details] [diff] [review]
Patch v1
Comment 3 Olli Pettay [:smaug] (vacation Aug 25-28) 2010-10-25 09:55:20 PDT
What is the status of the spec change?
Comment 4 Mounir Lamouri (:mounir) 2010-10-25 12:29:59 PDT
The bug still got no answer but I think we should ship with this change and see, this way, if there is a real need. FWIW, Jonas was supporting this plan.
Comment 5 Olli Pettay [:smaug] (vacation Aug 25-28) 2010-11-09 06:53:00 PST
Comment on attachment 484085 [details] [diff] [review]
Patch v1


>-:invalid {
>+:not(output):invalid {
>   box-shadow: 0 0 1.5px 1px red;
> }
> 
>+output:invalid {
>+  color: red;
>+}
>+

I think this change should get ui-review.
Comment 6 Alex Limi (:limi) — Firefox UX Team 2010-11-17 01:19:09 PST
Comment on attachment 484085 [details] [diff] [review]
Patch v1

If this works the way I think it does, it should be fine. I'm a bit hazy on the use of the HTML5 <output> element, and would love to see a demo of how this would be done in a real-life situation, though.

Don't let that stop this from shipping in a beta for wider feedback, though. :)
Comment 7 Mounir Lamouri (:mounir) 2010-11-17 16:03:36 PST
Pushed:
http://hg.mozilla.org/mozilla-central/rev/2eb1331a2bc4
Comment 8 Janet Swisher 2010-11-19 09:27:53 PST
I've documented this, and marked it as non-standard (https://developer.mozilla.org/en/DOM/HTMLOutputElement). If/when the spec is changed, we'll need to remove the non-standard label.

Note You need to log in before you can comment on or make changes to this bug.