spike of crashes [@ PL_DHashTableOperate | nsPresContext::GetRootPresContext() ]

RESOLVED DUPLICATE of bug 599341

Status

()

Core
Layout
--
critical
RESOLVED DUPLICATE of bug 599341
7 years ago
7 years ago

People

(Reporter: Scoobidiver (away), Unassigned)

Tracking

({crash, regression})

Trunk
x86
Windows 7
crash, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre

It is a residual crash signature with a low daily rate
But from b8pre/20101015 build, it becomes #3 top crasher.

Signature	PL_DHashTableOperate | nsPresContext::GetRootPresContext()
UUID	e57ee292-9308-4da7-984e-4ce342101015
Time 	2010-10-15 12:58:27.969713
Uptime	8714
Last Crash	11007 seconds (3.1 hours) before submission
Install Age	24433 seconds (6.8 hours) since version was first installed.
Product	Firefox
Version	4.0b8pre
Build ID	20101015042126
Branch	2.0
OS	Windows NT
OS Version	5.1.2600 Dodatek Service Pack 3
CPU	x86
CPU Info	AuthenticAMD family 16 model 4 stepping 3
Crash Reason	EXCEPTION_ACCESS_VIOLATION_READ
Crash Address	0x2c8
App Notes 	AdapterVendorID: 1002, AdapterDeviceID: 9714

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.c:615
1 	xul.dll 	nsPresContext::GetRootPresContext 	layout/base/nsPresContext.cpp:1120
2 	xul.dll 	nsObjectFrame::DestroyFrom 	layout/generic/nsObjectFrame.cpp:675
3 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
4 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
5 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
6 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
7 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
8 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
9 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
10 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
11 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
12 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
13 	xul.dll 	nsTableFrame::DestroyFrom 	layout/tables/nsTableFrame.cpp:269
14 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
15 	xul.dll 	nsTableOuterFrame::DestroyFrom 	layout/tables/nsTableOuterFrame.cpp:220
16 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
17 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
18 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
19 	xul.dll 	nsBlockFrame::DestroyFrom 	layout/generic/nsBlockFrame.cpp:316
20 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
21 	xul.dll 	nsCanvasFrame::DestroyFrom 	layout/generic/nsCanvasFrame.cpp:95
22 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
23 	xul.dll 	nsHTMLScrollFrame::DestroyFrom 	layout/generic/nsGfxScrollFrame.cpp:121
24 	xul.dll 	nsContainerFrame::DestroyFrom 	layout/generic/nsContainerFrame.cpp:272
25 	xul.dll 	ViewportFrame::DestroyFrom 	layout/generic/nsViewportFrame.cpp:73
26 	xul.dll 	nsFrameManager::Destroy 	layout/base/nsFrameManager.cpp:257
27 	xul.dll 	PresShell::Destroy 	layout/base/nsPresShell.cpp:2025
28 	xul.dll 	DocumentViewerImpl::DestroyPresShell 	layout/base/nsDocumentViewer.cpp:4299
29 	xul.dll 	DocumentViewerImpl::DestroyPresShell 	layout/base/nsDocumentViewer.cpp:4300
30 	xul.dll 	DocumentViewerImpl::Destroy 	layout/base/nsDocumentViewer.cpp:1619
31 	xul.dll 	DestroyViewerEvent::Run 	docshell/shistory/src/nsSHEntry.cpp:879
32 	xul.dll 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:547
33 	xul.dll 	mozilla::ipc::MessagePump::Run 	ipc/glue/MessagePump.cpp:110
34 	xul.dll 	xul.dll@0xae28d3 	
35 	xul.dll 	MessageLoop::RunHandler 	ipc/chromium/src/base/message_loop.cc:202
36 	xul.dll 	_SEH_epilog4 	
37 	xul.dll 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:176
38 	xul.dll 	nsBaseAppShell::Run 	widget/src/xpwidgets/nsBaseAppShell.cpp:180
39 	xul.dll 	xul.dll@0xae28d3 	
40 	xul.dll 	nsAppShell::Run 	widget/src/windows/nsAppShell.cpp:243

The regression range is :
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ad0a0be8be74&tochange=19cb42fa4554

More reports at:
http://crash-stats.mozilla.com/report/list?product=Firefox&version=Firefox%3A4.0b8pre&query_search=signature&query_type=exact&query=PL_DHashTableOperate%20|%20nsPresContext%3A%3AGetRootPresContext%28%29&range_value=&range_unit=weeks&hang_type=any&process_type=any&plugin_field=&plugin_query_type=&plugin_query=&do_query=1&admin=&signature=PL_DHashTableOperate%20|%20nsPresContext%3A%3AGetRootPresContext%28%29
For some reason the stack walking skipped a different frame, so frame 1 is different, but it's the same crash.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 599341
(Assignee)

Updated

7 years ago
Crash Signature: [@ PL_DHashTableOperate | nsPresContext::GetRootPresContext() ]
You need to log in before you can comment on or make changes to this bug.