Closed Bug 604869 Opened 11 years ago Closed 11 years ago

Add highlighting in the Add-on Manager Appearance view for current theme

Categories

(Toolkit :: Add-ons Manager, defect)

defect
Not set
normal

Tracking

()

VERIFIED FIXED
mozilla2.0b8

People

(Reporter: mozbugz, Assigned: Unfocused)

References

Details

User-Agent:       Mozilla/5.0 (Windows NT 6.1; rv:2.0b8pre) Gecko/20101015 Firefox/4.0b8pre
Build Identifier: 

I would like to have a way to quickly identify which theme I have enabled by having it be highlighted or something.  Its hard to spot in a list of 30 or so items.  It would probably also help our Disability case here too.

Reproducible: Always

Steps to Reproduce:
1. Install lots of personas
2. Install several themes
3. enable a different theme by default
Actual Results:  
Its hard to locate in the list which is themes, and which are personas and which one is enabled without checking either for the button which is changed or the wording doesn't have (disabled)

Expected Results:  
 Either it should be shown at the very top which one is enabled, or just have the item stand out like Extensions, maybe it could be green or something.

I should be able to identity what I have in less than 1 scroll through the entire list.  Currently it takes too long to find, since I was looking for my current theme which I wanted to share feedback with the developer.
Component: General → Add-ons Manager
Product: Firefox → Toolkit
Version: unspecified → Trunk
I think the changes in bug 601022 make this much more obvious to notice.
Assignee: nobody → bmcbride
Blocks: 601022
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86 → All
QA Contact: general → add-ons.manager
Summary: Add hightlighting in the Add-on Manager Appearance view for current theme → Add highlighting in the Add-on Manager Appearance view for current theme
No longer blocks: 601022
Depends on: 601022
Whiteboard: [needs 601022]
(In reply to comment #2)
> I think the changes in bug 601022 make this much more obvious to notice.

Right. But for the final solution we need bug 520124 fixed.
Depends on: 520124
No longer depends on: 601022
Whiteboard: [needs 601022]
I'd still call this fixed - regardless of whether bug 520124 is fixed or not, the current theme is now very obvious.
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Depends on: 601022
No longer depends on: 520124
Resolution: --- → FIXED
Ok, so lets mark it as verified then. You are right, the highlight exists.

I assume we have a couple of automated tests? In any way this will also be a sub-step of a litmus test.
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
Flags: in-litmus?
Target Milestone: --- → mozilla2.0b8
(In reply to comment #5)
> I assume we have a couple of automated tests?

The testable code is tested, though there's no new tests specifically for this bug. Its hard to test whether something looks good, which was 99% of that work. The litmus test would be something like "disabled extensions/plugins/themes look dimmed/grey, enabled extensions/plugins/themes do not".
Flags: in-testsuite? → in-testsuite-
Manual test covered by:
https://litmus.mozilla.org/show_test.cgi?id=10157
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.