D3D10 layers and Direct2D are disabled by default and cannot be force-enabled on Windows 7 with Intel G965 / x3000.

REOPENED
Unassigned

Status

()

--
major
REOPENED
8 years ago
2 years ago

People

(Reporter: anurag4love, Unassigned)

Tracking

(Depends on: 2 bugs)

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [platform-rel-Intel])

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b8pre) Gecko/20101016 Firefox/4.0b8pre

The new Direct2D acceleration fails to start on G965/GMA x3000 Integrated Graphics. 

Direct2D is not enabled even if the parameter gfx.direct2d.force-enabled is set to true. 

Reproducible: Always

Steps to Reproduce:
1. Start Minefield with fresh profile on system with Intel G965/ GMAx3000.
2. Check about Direct2D status from about:support

Actual Results:  
Direct2D status is false. Direct2D acceleration is not enabled as evident from running demonstration benefiting from it. 

Expected Results:  
Direct2D should be enabled and used.

Device ID: 29a2
Vendor ID: 8086

1. Internet Explorer 9 Beta can utilize Direct2D. 
2. Fresh profile and fresh OS install don't help in enabling the feature.
3. The bug can be reproduced on both Windows 7 x86 and x64 , with x86 build of Minefield.
4. Direct3D9 is enabled by default. DirectWrite us disabled by default, although it can be force-enabled.
Can you provide a full graphic section of the "about:support" page ?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Direct2D cannot be enabled on Intel G965 / x3000. → Direct2D is disabled by default and cannot be forced to enabled on Intel G965 / x3000.
Version: unspecified → Trunk
(Reporter)

Updated

8 years ago
Summary: Direct2D is disabled by default and cannot be forced to enabled on Intel G965 / x3000. → Direct2D is disabled by default and cannot be force-enabled on Intel G965 / x3000.
(Reporter)

Comment 2

8 years ago
(In reply to comment #1)
> Can you provide a full graphic section of the "about:support" page ?

Following is the complete details. Note that I have the latest driver version and I have confirmed on other bug pages that device-id 29a2 is not being explicitly blocked.

Graphics

        Adapter Description
        Intel(R)  G965 Express Chipset Family

        Vendor ID
        8086

        Device ID
        29a2

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumd64 igdumdx32

        Driver Version
        8.15.10.1930

        Driver Date
        9-23-2009

        Direct2D Enabled
        false

        DirectWrite Enabled
        false

      GPU Accelerated Windows
      1/1 Direct3D 9
(Reporter)

Comment 3

8 years ago
(In reply to comment #1)
> Can you provide a full graphic section of the "about:support" page ?

Following is the complete details. Note that I have the latest driver version and I have confirmed on other bug pages that device-id 29a2 is not being explicitly blocked.

Graphics

        Adapter Description
        Intel(R)  G965 Express Chipset Family

        Vendor ID
        8086

        Device ID
        29a2

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumd64 igdumdx32

        Driver Version
        8.15.10.1930

        Driver Date
        9-23-2009

        Direct2D Enabled
        false

        DirectWrite Enabled
        false

      GPU Accelerated Windows
      1/1 Direct3D 9

Updated

8 years ago
Depends on: 605053
Anurag, is it fixed now in the latest nightlies?
Summary: Direct2D is disabled by default and cannot be force-enabled on Intel G965 / x3000. → Direct2D is disabled by default and cannot be force-enabled on Windows 7 with Intel G965 / x3000.
(Reporter)

Comment 5

8 years ago
As of 03 Feb 2011 GMT, the bug has not been fixed with latest availible nightly build. The current about:support states, (with fresh profile)

 Graphics

        Adapter Description
        Intel(R)  G965 Express Chipset Family

        Vendor ID
        8086

        Device ID
        29a2

        Adapter RAM
        Unknown

        Adapter Drivers
        igdumd64 igdumdx32

        Driver Version
        8.15.10.1930

        Driver Date
        9-23-2009

        Direct2D Enabled
        false

        DirectWrite Enabled
        false (6.1.7600.20830, font cache n/a)

        WebGL Renderer
        Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.541)

        GPU Accelerated Windows
        1/1 Direct3D 9
This can only be a driver issue and/or a limitation of this graphics card making it fail during D2D initialization. Not much that we can do to help. The starting point would be to debug this to see precisely where it's failing.

It would be interesting to know if any other D2D app works on your system. For example, IE9  (assuming there's a way to tell whether it's using D2D)
Your GPU has a maximum texture size of 2048, but Firefox requires 4096.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 8

8 years ago
D2D Works fine in IE9, and  apps written with WMF. For example,

1. Performance in IE9 -> http://i.imgur.com/o3biG.png
2. Performance in FF4 -> http://i.imgur.com/9v7HK.png

DirectWrite will also work on my Hardware should I force enable it.
(Reporter)

Comment 9

8 years ago
Also, as listed here -> http://software.intel.com/en-us/articles/intel-gma-3000-and-x3000-developers-guide/

For G965, Max 3D texture is 8092 x 8092 x 256.
Maximum 2D texture size is 4K x 4K which I hope implies 4096 (1k = 1024?)

Apart from that, G965 in fully supporting Pixel Shader 3.
Yeah, indeed, it's not clear why it's failing, since this intel site says that it's supporting 4K textures.

Together with the fact that IE9 is happily doing D2D here (see benchmark result), I'm reopening this.

But working on it is going to be tedious until some developer can reproduce the issue.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Oh, look --- it's using D3D9 layers. This means that D3D10 failed. So the problem is about D3D10, not D2D specific.
Summary: Direct2D is disabled by default and cannot be force-enabled on Windows 7 with Intel G965 / x3000. → D3D10 layers and Direct2D are disabled by default and cannot be force-enabled on Windows 7 with Intel G965 / x3000.

Comment 12

7 years ago
Have you tried updated drivers according to
https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers ? Then, try with Firefox 7.

Comment 13

7 years ago
I have. (In reply to :aceman from comment #12)
> Have you tried updated drivers according to
> https://wiki.mozilla.org/Blocklisting/Blocked_Graphics_Drivers ? Then, try
> with Firefox 7.

I have. I have the exact version mentioned on both my Windows XP and Windows 8 partitions. On Windows 8 I even downgraded to make sure it didn't have to be the exact version. Granted, mine is the 950, not the 965, but I was told to respond here in Bug 604771. I'm guessing it's probably the same basic issue.

I may play around with 3D Analyze, and see if I can trick Firefox into thinking the card is compatible.

Comment 14

7 years ago
Oh, and here's the graphics section of my about:support on Windows XP. (I'll do Windows 8 in a bit)

Adapter Description: Mobile Intel(R) 945 Express Chipset Family
Vendor:              ID0x8086
Device:              ID0x27ae
Adapter RAM:         Unknown
Adapter Drivers:     igxprd32
Driver Version:      6.14.10.4926
Driver Date:         2-15-2008
WebGL Renderer:      Google Inc. -- ANGLE (Mobile Intel(R) 945 Express Chipset Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)GPU Accelerated Windows0

Comment 15

7 years ago
Forgot to note in previous responses that I'm using the latest 14.0 beta (as of this post.) I'd tell you which beta, but it's not mentioned in about: or about:support. 

Adapter Description      Mobile Intel(R) 945 Express Chipset Family
Vendor ID                0x8086
Device ID                0x27ae
Adapter RAM              Unknown
Adapter Drivers          igdumd32
Driver Version           8.15.10.1930
Driver Date              9-23-2009
Direct2D Enabled         Blocked for your graphics driver version.
DirectWrite Enabled      true (6.2.8400.0)
ClearType Parameters     Gamma: 1800 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 
WebGL Renderer           Google Inc. -- ANGLE (Mobile Intel(R) 945 Express Chipset Family) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows  0
Depends on: 773978
Whiteboard: [platform-rel-Intel]
platform-rel: --- → ?
platform-rel: ? → ---
You need to log in before you can comment on or make changes to this bug.