Gmail Inbox not loading in standard view

VERIFIED FIXED in mozilla2.0b7

Status

()

VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: ahoza, Assigned: bsterne)

Tracking

Trunk
mozilla2.0b7
ARM
All
Points:
---

Firefox Tracking Flags

(status1.9.2 .13-fixed, status1.9.1 unaffected)

Details

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 years ago
Created attachment 483914 [details]
Screenshot

Device: Nokia N900
BuildID: Mozilla /5.0 (Maemo;Linux armv7l;rv:2.0b8pre)Gecko/20101017 Firefox/4.0b8pre Fennec /4.0b2pre 

Device: HTC Desire
BuildID: Mozilla /5.0 (Android;Linux armv7l;rv:2.0b8pre) Gecko/20101017 Firefox/4.0b8pre Fennec /4.0b2pre 

Steps to reproduce:

1. Start Fennec.
2. Load gmail.com and enter credentials.

Expected results:
Gmail Inbox page is displayed.

Actual results: 
"This is taking longer than usual" is displayed (see atached screenshot)
If one chooses "basic HTML view" link in that page, Gmail Inbox loads.

Note: Gmail Inbox page loads properly, in standard view, when using native browser. This should happen with Fennec as well.
reproducible already on 20101015
regressed at central 5b8582013988->5fcb86d51691, mobile d46fdbdbe45f->d46fdbdbe45f (sic)
c5494ee56c47 was good
No longer blocks: 561051
(Assignee)

Comment 6

8 years ago
Can you put a breakpoint in nsDSURIContentListener::CheckFrameOptions and see where you return and what is returned?

Comment 7

8 years ago
(In reply to comment #6)
> Can you put a breakpoint in nsDSURIContentListener::CheckFrameOptions and see
> where you return and what is returned?

After beginning to load gmail I get one return from http://mxr.mozilla.org/mozilla-central/source/docshell/base/nsDSURIContentListener.cpp#311 and then 4 returns http://mxr.mozilla.org/mozilla-central/source/docshell/base/nsDSURIContentListener.cpp#341.

Comment 8

8 years ago
Created attachment 484638 [details] [diff] [review]
Patch to fix gmail loading

I didn't quite get what is the essential difference here but when looking at the changes http://hg.mozilla.org/mozilla-central/rev/f5c0015afe0e and http://hg.mozilla.org/mozilla-central/rev/5fcb86d51691 I noticed the while-loop having a different form in the condition. With this "older" form of the condition gmail inbox gets loaded ok.
Attachment #484638 - Flags: review?(jst)

Updated

8 years ago
Attachment #484638 - Flags: review?(bsterne)

Comment 9

8 years ago
>-        while (NS_SUCCEEDED(curDocShellItem->GetParent(getter_AddRefs(parentDocShellItem)) &&
>-                            parentDocShellItem)) {

Here's the problem: the NS_SUCCEEDED call includes the && parentDocShellItem condition.  Guh.
(Assignee)

Comment 10

8 years ago
Created attachment 484695 [details] [diff] [review]
patch (per comment 9)

(In reply to comment #9)
> Here's the problem: the NS_SUCCEEDED call includes the && parentDocShellItem
> condition.  Guh.

Yep. Pekka, can you test this patch to see if it fixes the Gmail problem?
Attachment #484638 - Attachment is obsolete: true
Attachment #484638 - Flags: review?(jst)
Attachment #484638 - Flags: review?(bsterne)
(Assignee)

Comment 11

8 years ago
I'm curious why this only shows up on Fennec, but I suspect Josh is right and hopefully the patch fixes us there.

Updated

8 years ago
Attachment #484695 - Flags: review+
Attachment #484695 - Flags: approval2.0+
(Assignee)

Comment 12

8 years ago
This is the right fix.  The condition is wrong for both Firefox and Fennec but we survive on Fennec because we hit the break after finding a chrome docshell.  Since we don't find such a chrome docshell on Fennec, we enter the while loop an additional time with parentDocShell == null so we can't find a topDoc and thus return false blocking the frame from loading.  Thanks for catching this.

http://hg.mozilla.org/mozilla-central/rev/2ccdeb31509b
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 13

8 years ago
(In reply to comment #12)
> This is the right fix.  The condition is wrong for both Firefox and Fennec but
> we survive on Fennec

Should have read "survive on Firefox".

Comment 14

8 years ago
(In reply to comment #12)
> This is the right fix.  
> ...
> http://hg.mozilla.org/mozilla-central/rev/2ccdeb31509b

Yes, this works. Thanks.

Comment 15

8 years ago
Verified on Build:

Mozilla/5.0(Android; Linux armv7l; rv:2.0b8pre) Gecko/20101021 Firefox/4.0b8pre
Fennec/4.0b2pre
Status: RESOLVED → VERIFIED
Assignee: nobody → bsterne
Component: General → DOM: Core & HTML
Product: Fennec → Core
QA Contact: general → general
Target Milestone: --- → mozilla2.0b7
Comment on attachment 484695 [details] [diff] [review]
patch (per comment 9)

I assume we also need this on 1.9.2 since we just took the regressing patch.
Attachment #484695 - Flags: approval1.9.2.13?
Comment on attachment 484695 [details] [diff] [review]
patch (per comment 9)

Approved for 1.9.2.13, a=dveditz
Attachment #484695 - Flags: approval1.9.2.13? → approval1.9.2.13+

Updated

8 years ago
status1.9.1: --- → unaffected
You need to log in before you can comment on or make changes to this bug.