Last Comment Bug 605292 - Update hg on Mac and Windows slaves to 1.7.5 (1.3 or greater)
: Update hg on Mac and Windows slaves to 1.7.5 (1.3 or greater)
Status: RESOLVED FIXED
[buildslave][puppet][opsi]
:
Product: Release Engineering
Classification: Other
Component: Other (show other bugs)
: other
: x86_64 Linux
: P3 normal (vote)
: ---
Assigned To: Chris AtLee [:catlee]
:
Mentors:
Depends on:
Blocks: 589885 627576
  Show dependency treegraph
 
Reported: 2010-10-18 15:08 PDT by Syed Albiz [:salbiz]
Modified: 2013-08-12 21:54 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Upgrade hg on mac build machines to 1.7.5 (4.24 KB, patch)
2011-02-16 13:05 PST, Chris AtLee [:catlee]
bhearsum: review+
catlee: checked‑in+
Details | Diff | Review

Description Syed Albiz [:salbiz] 2010-10-18 15:08:19 PDT
This would make speeding up shared source checkout much easier via the hg share extension, which is only available in hg 1.3+.
Comment 1 Nick Thomas [:nthomas] 2010-10-20 13:35:50 PDT
The moz2-darwin10 (macosx64) slaves have 1.4.2, while moz2-darwin9 (macosx) have 1.2.1. I'd like having everything the same as 1.6.3 on linux if we can.
Comment 2 Syed Albiz [:salbiz] 2010-10-22 14:56:39 PDT
Based on discussion in IRC, looks like we want to go with upgrading all machines to hg 1.6.4 as this gives us the option of verified https checkouts.
Comment 3 Chris AtLee [:catlee] 2011-02-07 07:41:34 PST
yoink
Comment 4 Chris AtLee [:catlee] 2011-02-10 06:32:11 PST
mercurial and mercurial-hgrc packages are in production-opsi now, waiting for deployment
Comment 5 Chris AtLee [:catlee] 2011-02-16 13:05:05 PST
Created attachment 512892 [details] [diff] [review]
Upgrade hg on mac build machines to 1.7.5
Comment 6 Chris AtLee [:catlee] 2011-02-18 08:16:48 PST
New hg is rolling out to mac machines now.
Comment 7 Armen Zambrano [:armenzg] - Engineering productivity 2013-03-25 08:23:53 PDT
Added win32 info to ref docs:
https://wiki.mozilla.org/ReferencePlatforms/Win32#Install_Mercurial_1.7.5

Note You need to log in before you can comment on or make changes to this bug.