The default bug view has changed. See this FAQ.

Non-english templates are no longer precompiled by checksetup

RESOLVED FIXED in Bugzilla 3.6

Status

()

Bugzilla
Installation & Upgrading
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: Frédéric Buclin, Assigned: Frédéric Buclin)

Tracking

({regression})

3.6.2
Bugzilla 3.6
regression
Bug Flags:
approval +
approval4.0 +
blocking4.0 +
approval3.6 +
blocking3.6.3 -

Details

Attachments

(2 attachments)

(Assignee)

Description

7 years ago
This is a regression due to bug 430012: checksetup.pl no longer precompiles templates except english and your local language. That's because precompile_templates() calls template_include_path(), which itself calls include_languages() which limits the list of languages to the ones you use. This means that all my installations with several l10n templates on them have no precompiled l10n templates, which makes Bugzilla slower the first time you visit them, but also all the permissions are wrong because instead of lpsolit:apache, they all have apache:apache, which prevents me from deleting them (data/deleteme/ becomes larger every time I run checksetup.pl, with no way to delete it).
Flags: blocking4.0?
Flags: blocking3.6.3?
(Assignee)

Updated

7 years ago
Summary: Non english-templates are no longer compiled → Non-english templates are no longer compiled

Comment 1

7 years ago
  Hmm. Yes, I suppose only the templates that are in the template search patch will be recompiled. I bet it has more to do with localizing checksetup than it does with the template include changes, but they're both probably related.

  We'll see how involved the fix is. If it's small, we'll take it for 3.6.x, but I don't want to block 3.6.x on it.
Flags: blocking4.0?
Flags: blocking4.0+
Flags: blocking3.6.3?
Flags: blocking3.6.3-

Updated

7 years ago
Summary: Non-english templates are no longer compiled → Non-english templates are no longer precompiled by checksetup
(Assignee)

Comment 2

7 years ago
Created attachment 484740 [details] [diff] [review]
patch, v1
Assignee: installation → LpSolit
Status: NEW → ASSIGNED
Attachment #484740 - Flags: review?(mkanat)

Comment 3

7 years ago
Comment on attachment 484740 [details] [diff] [review]
patch, v1

Oh, that's actually a pretty good idea! :-) Wow, super-simple fix, and it looks like it will work just fine. :-) Thanks!
Attachment #484740 - Flags: review?(mkanat) → review+

Updated

7 years ago
Flags: approval4.0+
Flags: approval3.6+
Flags: approval+
(Assignee)

Comment 4

7 years ago
Created attachment 484868 [details] [diff] [review]
patch for 3.6, v1

The previous patch doesn't apply cleanly for 3.6.
Attachment #484868 - Flags: review?(mkanat)

Updated

7 years ago
Attachment #484868 - Flags: review?(mkanat) → review+
(Assignee)

Comment 5

7 years ago
Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/trunk/
modified Bugzilla/Template.pm
modified Bugzilla/Install/Util.pm
Committed revision 7553.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/4.0/
modified Bugzilla/Template.pm
modified Bugzilla/Install/Util.pm
Committed revision 7448.

Committing to: bzr+ssh://lpsolit%40gmail.com@bzr.mozilla.org/bugzilla/3.6/
modified Bugzilla/Template.pm
modified Bugzilla/Install/Util.pm
Committed revision 7193.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.