Thunderbird message-printing: text without specified color is printed with system default color

UNCONFIRMED
Unassigned

Status

MailNews Core
Printing
UNCONFIRMED
8 years ago
7 years ago

People

(Reporter: nitr0, Unassigned)

Tracking

1.9.2 Branch
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

63.69 KB, application/pdf
Details
(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.10) Gecko/20100914 Firefox/3.6.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.9) Gecko/20100915 Thunderbird/3.1.4

If I tried to print message with text without forced color (for ex., usual text message) - I get on output text with system default color (in my case - light-green). This isn't trouble for most users (which uses default 'black-on-white' themes), but will result in unreadable output for dark (inverted) color schemes, with dark background and light/white text.

Reproducible: Always

Steps to Reproduce:
1. Set some dark theme with white text color
2. Open plaintext message
3. Try to print it
Actual Results:  
Printed white text

Expected Results:  
Printed black text

Comment 1

7 years ago
nitr0, does this also happen with version 5?
Joe, can you confirm?
Component: General → Printing
Product: Thunderbird → MailNews Core
QA Contact: general → printing
Version: unspecified → 1.9.2 Branch

Comment 2

7 years ago
Just tried a high contrast (white on black) theme, and could not reproduce here.
Seems the choices (black text white background) in Options>>Display  Colors were followed in the print action.
Tested in current trunk.

Comment 3

7 years ago
nitr0, please reopen if you can reproduce using newer version
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

7 years ago
Created attachment 574625 [details]
Sample output

Sample printing output
(Reporter)

Comment 5

7 years ago
In 8.0 things are worse - now printed text with background color specified in Thunderbird color scheme config. Sample .pdf is attached above.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
You need to log in before you can comment on or make changes to this bug.