If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

update minidump_stackwalk in Socorro production to latest Breakpad SVN (r715)

RESOLVED FIXED

Status

mozilla.org Graveyard
Server Operations
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: ted, Assigned: jabba)

Tracking

Details

+++ This bug was initially created as a clone of Bug #601114 +++

I landed some stackwalker fixes in Breakpad for bug 601312 . We need to update the production minidump_stackwalk binaries to the latest Breakpad SVN (r715 or newer) to pick these changes up.

Updated

7 years ago
Assignee: server-ops → jdow
(Assignee)

Comment 1

7 years ago
Any downtime needed for this? I don't remember if this was already updated in stage?

Comment 2

7 years ago
(In reply to comment #1)
> Any downtime needed for this? I don't remember if this was already updated in
> stage?

If it wasn't, then we need to do that first.
We didn't take a downtime last time, but we did test in staging first. Testing this will be...slightly harder since I don't have a reproducible testcase for the problematic crashes, but I'll try to figure it out.
(Assignee)

Comment 4

7 years ago
[processor@dm-breakpad-stage01 google-breakpad]$ pwd
/home/processor/google-breakpad
[processor@dm-breakpad-stage01 google-breakpad]$ svn info
Path: .
URL: http://google-breakpad.googlecode.com/svn/trunk
Repository Root: http://google-breakpad.googlecode.com/svn
Repository UUID: 4c0a9323-5329-0410-9bdc-e9ce6186880e
Revision: 710
Node Kind: directory
Schedule: normal
Last Changed Author: ted.mielczarek
Last Changed Rev: 710
Last Changed Date: 2010-10-05 12:39:23 -0700 (Tue, 05 Oct 2010)

[processor@dm-breakpad-stage01 google-breakpad]$ 


Looks like stage is at rev 710. I shall update this first.
(Assignee)

Comment 5

7 years ago
Stage is up to date. Let me know when we are satisfied that everything is working before I push to prod.
(Assignee)

Comment 6

7 years ago
When should this go go prod? Is there any testing in stage that needs to be done by qa or IT?
Looks good on stage:
http://crash-stats.stage.mozilla.com/report/index/8dc72891-cb8d-49c9-a456-0d41f2101020
I resubmitted this crash from production (for comparison):
https://crash-stats.mozilla.com/report/index/1aeae141-c5d0-4a74-b4be-c17a72101020
Justin: sorry, I was trying to test it yesterday but the staging collector was acting up, then I hit a bug with the search form, and didn't get back to it till just now. We can roll this out to production whenever you're ready.
(Assignee)

Comment 9

7 years ago
Production has been updated.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.