Closed Bug 605813 Opened 9 years ago Closed 4 years ago

Re-enable test_taskbar_progress.xul on Windows

Categories

(Core :: Widget: Win32, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla44
Tracking Status
firefox44 --- fixed
blocking2.0 --- -

People

(Reporter: rain1, Assigned: Felipe)

References

Details

Via bug 548763 comment 30, and I can reproduce locally, the test fails with 

Error: uncaught exception: [Exception... "Component returned failure code:
0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIWinTaskbar.getTaskbarProgress]" 
nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame ::
chrome://mochikit/content/chrome/widget/tests/taskbar_progress.xul :: loaded ::
line 48"  data: no]

The reason we haven't caught it yet is because we weren't running the test at all: see bug 605812.
blocking2.0: --- → ?
Well, you wrote it :)

Is a bad enough failure that it indicates something is seriously wrong that we shouldn't release without?
Assignee: nobody → sid.bugzilla
(In reply to comment #1)
> Well, you wrote it :)

I only wrote the patch, not the test. Felipe wrote the test :)
(In reply to comment #1)
> Is a bad enough failure that it indicates something is seriously wrong that we
> shouldn't release without?

I don't think so -- taskbar progress definitely still works.
I didn't write this test! I only wrote the front-end tests.

I'll take a look later today, I guess this could be one of the inner/outer window changes from brain transplants.
Sorry, jmathies did.
Blocks: 605812
Summary: taskbar_progress.xul mochitest fails on Windows 7 → taskbar_progress.xul and taskbar_previews.xul mochitests fail on Windows 7
(In reply to comment #5)
> Sorry, jmathies did.

I think rob put these together, although I probably r+'m.

Regardless of who wrote them, who wants to look into this?
Felipe! He said so in comment 4.
Assignee: sid.bugzilla → felipc
Not blocking based on comment 3, but I'll listen to arguments otherwise, and I'd take a patch.
blocking2.0: ? → -
I wrote the previews one but not the progress ones. What's the error on the previews one? I can help fix that for sure.

My wild guess on the progress error is that we're giving it the wrong docShell. We should take the one from the appropriate toplevel XUL window.
(In reply to comment #10)
> I wrote the previews one but not the progress ones. What's the error on the
> previews one? I can help fix that for sure.

It's the same error for both previews and progress -- failure in getTaskbarState.
It seems to be a regression from 130078:

  HWND toplevelHWND = ::GetAncestor(GetHWNDFromDocShell(shell), GA_ROOT);

  if (!toplevelHWND)
    return NS_ERROR_INVALID_ARG;
What fails is GetHWNDFromDocShell, as the docshell passed (gBrowser.docShell) is the content's docshell, which no longer have a native window.
No longer depends on: 726144
I fixed test_taskbar_progress and re-enabled it on Windows. It worked well on try:
https://treeherder.mozilla.org/#/jobs?repo=try&revision=00930a723e66

I didn't touch test_taskbar_previews.xul because that might significantly change anyway with the e10s work in bug 1096804, so it's better to leave it to that bug.
Summary: taskbar_progress.xul and taskbar_previews.xul mochitests fail on Windows 7 → Re-enable test_taskbar_progress.xul on Windows
https://hg.mozilla.org/mozilla-central/rev/80ff21ac7b5c
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla44
You need to log in before you can comment on or make changes to this bug.