View Source not updated when form submitted and url unchanged (Build: 200101015)

VERIFIED DUPLICATE of bug 59642

Status

()

Core
HTML: Form Submission
P3
normal
VERIFIED DUPLICATE of bug 59642
17 years ago
17 years ago

People

(Reporter: Andreas Pauley, Assigned: rods (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Hi,
If a form on an html page is submitted to itself (causing the url to remain
unchanged), the "View Page Source" function will show the source code of the
original page, regardless of whether the source code for the page has changed or
not.

For instance, I have a php script called "register.php" that displays a
resistration form by default. Viewing the source of this page shows me all the
code of my form etc. Very nice.
If I submit this form (to itself), my php program does some sinister stuff with
the newly received information and then displays an innocent "Thank you for
registering" message. If I try to view source at this point in time, mozzilla is
convinced that I still want to see the source code of my original form instead
of my innocent message. I don't.

Hope this provides enough relevant info :-)

Andreas.

*** This bug has been marked as a duplicate of 59642 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
Verified, this is a duplicate of bug 59642 "View Source re-shows original page."
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.