when running jsreftests on a tegra, I get 45 tests that fail and are Date() related because tests don't work when timezone is UTC

RESOLVED DUPLICATE of bug 530974

Status

()

Core
JavaScript Engine
RESOLVED DUPLICATE of bug 530974
8 years ago
8 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile_unittests])

(Reporter)

Description

8 years ago
I ran the jsreftests end to end and had 76 failures where 45 of them appear to be Date() related.

here is the complete log:
http://people.mozilla.org/~jmaher/jsreftest.log

here is a grep of TEST-UNEXPECTED-FAIL | grep -i date:
http://people.mozilla.org/~jmaher/jsreftest_datefail.log
(mostly in ecma/Date/15.9.5.8.js and ecma/Date/15.9.5.28-1.js)

This seems like we most likely have a common problem to resolve.

Comment 1

8 years ago
what does (new Date(1130803199999)).getMonth() give on the tegra?
I get the right thing on my i9000 and nexus one. Although the throbber on my i9000 never seems to stop throbbing which is probably a different bug.

Can someone with a tegra try http://lassey.us/date.html please?
(Reporter)

Comment 3

8 years ago
fyi, this is on android nightly build from 2010-10-19.

Here is the culprit for 40 of the 45 failures:
http://mxr.mozilla.org/mozilla-central/source/js/src/tests/ecma/Date/15.9.5.8.js#96

What we do in this code is add test cases for what I think is the first second of each month.  Then for the failing tests we expect the wrong month inside the MonthFromLocalTime() call, but get it right on the Date.getMonth() call.

We only fail on months 3-10, not 0,1,2,11.  


I ran this on my n900 with a nightly build from 2010-10-07 using the same technique and I get these 40 tests passing.  I will investigate the other 5 date related failures in another comment.  So for this specific test case, android is the culprit (not fennec, remote testing, or general cross compiling)
(Reporter)

Comment 4

8 years ago
ok, this is a problem with the tests as they fail if the device has a timezone set to UTC.  We should fix the tests so they work on any timezone.
Component: General → Reftest
Product: Fennec → Testing
QA Contact: general → reftest
(Reporter)

Updated

8 years ago
Whiteboard: [mobile_unittests] [mobile_dev_needed] → [mobile_unittests]
Assignee: nobody → general
Component: Reftest → JavaScript Engine
Product: Testing → Core
QA Contact: reftest → general
Summary: when running jsreftests on a tegra, I get 45 tests that fail and are Date() related → when running jsreftests on a tegra, I get 45 tests that fail and are Date() related because tests don't work when timezone is UTC
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 530974
You need to log in before you can comment on or make changes to this bug.