Fennec throbber spins forever on page that calls document.write

NEW
Unassigned

Status

defect
9 years ago
6 months ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
When you open this URL in Fennec, the throbber never stops spinning:

data:text/html,<body%20onload=document.write("foo")>
(Reporter)

Updated

9 years ago
tracking-fennec: --- → ?
Isn't this just a dupe of bug 81980?
(Reporter)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 81980
(Reporter)

Comment 3

9 years ago
Hmm, actually this seems different.  The testcase does not throb forever in Minefield, and it does throbs forever in Fennec even if you add a call to document.close:

data:text/html,<body%20onload='document.write("foo");document.close();'>
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
tracking-fennec: ? → 2.0b3+
Status: NEW → ASSIGNED
matt, stealing.
Assignee: mbrubeck → doug.turner
tracking-fennec: 2.0b3+ → 2.0-
this maybe a dup of existing wysiwyg bug.  Either way, we don't think we should block fennec.
Assignee: doug.turner → nobody
Whiteboard: [fennec-4.1?]
tracking-fennec: - → ?
Summary: Fennec throbber spins forever on page that calles document.write → Fennec throbber spins forever on page that calls document.write
Whiteboard: [fennec-4.1?]
tracking-fennec: ? → -
No assignee, updating the status.
Status: ASSIGNED → NEW
tracking-fennec: - → ---
No assignee, updating the status.
No assignee, updating the status.
No assignee, updating the status.
No assignee, updating the status.
You need to log in before you can comment on or make changes to this bug.