"_blank" and "_new" window targets broken in Gtk embed browser

VERIFIED DUPLICATE of bug 60338

Status

Core Graveyard
Embedding: GTK Widget
P3
normal
VERIFIED DUPLICATE of bug 60338
18 years ago
6 years ago

People

(Reporter: rusty.lynch, Assigned: Stuart Parmenter)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Attempting to load content with a window target of "_blank" or "_new" will
result in the content being loaded in the main window along with some other
flakey behavior (like the history being trashed.)

From what I have seen, the method for opening the window doesn't seem to matter.
I see the bug with anchors using the target argument, form submission using the
target argument, and window.open calls.

I will attach a HTML testcase.
(Reporter)

Comment 1

18 years ago
Created attachment 19459 [details]
HTML testcase for GTK embedded browser.

Comment 2

18 years ago
Related: embed issues regarding _new and _blank are reported in bug 60338

(Reporter)

Comment 3

18 years ago
Marking this as a duplicate of bug #60338 since it was logged first.

*** This bug has been marked as a duplicate of 60338 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
vrfy dup
Status: RESOLVED → VERIFIED
Component: Embedding: GTK Widget → Embedding: GTK Widget
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.