All users were logged out of Bugzilla on October 13th, 2018

Dragging sidebar causes weird behavior

RESOLVED WORKSFORME

Status

P3
normal
RESOLVED WORKSFORME
18 years ago
13 years ago

People

(Reporter: hwaara, Assigned: samir_bugzilla)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20001118

This is what I do to reproduce the bug, it's always reproducable:

1. Click on the little sidebar-dragging area, but don't release the button yet.
2. Drag it..

(here is another bug which is depending on the first one)

3. Now drop it somewhere else.
4. Try to close the sidebar in it's open state.

Actual results: The sidebar opens AND wants me to drop the "dragging-line"
somewhere. When i drop it, I get problems to close the sidebar.

Comment 1

18 years ago
What do you mean by "closing in open state " ? Do you mean to close it thru 
"View|My Sidebar" ? or use the grippy and double click on  it to hide it? Pls 
let me know and wha texactly is the problem you see here? Which is the first 
problem and which is the second?  What theme is this seen on ? Thx !
(Reporter)

Comment 2

18 years ago
I am using both "Mozillum Modern" and "Modern" as my themes. And by the way, I 
checked with a friend and got to know that the second "bug" wasn't really a bug.

But the first one still is. The problem there is that when I drag the sidebar - 
which is next to the browsing-area - it opens the sidebar AND shows me a 
dragged sidebar. If this isn't a bug it sure is confusing.. I don't want 
sidebar to open if my drag isn't yet completed.

Sorry for my english.

Comment 3

18 years ago
cc pmac. I stil do not understand this bug. Sidebar will open when you are 
dragging it...that's how it works...

Comment 4

18 years ago
Yeah, my checkin a couple days caused this.

To see this (on Windows), go to the Display Properties applet (accessible from 
Control Panel), switch to the Effects tab, uncheck "Show window contents while 
dragging," start Mozilla, collapse the sidebar (click the grippy), and then 
start dragging (to the right).  The sidebar opens even though it shouldn't be a 
live resize, e.g. it should only open after you let go of the mouse button.

-> me
Assignee: matt → blakeross
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 5

18 years ago
There you go, that was the bug I was talking about.

Comment 6

18 years ago
Aahhhhhh.. thanks! ;)

Updated

18 years ago
OS: Windows 98 → All
Hardware: PC → All
Summary: Dragging sidebar causes wierd behaviour → Dragging sidebar causes weird behavior

Comment 7

18 years ago
Eric, can you point me to where this code (to pop open the sidebar) is 
located?  I can't seem to find it...
(Reporter)

Comment 8

18 years ago
Created attachment 21395 [details]
This is how it (still) looks like when I'm attempting to drag-open the sidebar from a closed state to an open.

Comment 9

18 years ago
spam : changing qa to sujay (New Sidebar QA)
QA Contact: shrir → sujay
(Reporter)

Comment 10

18 years ago
blake, can't you fix this for 0.9? pretty please?  ;)

Comment 11

18 years ago
usability/polish 0.9.4.
Target Milestone: mozilla1.0 → mozilla0.9.4

Updated

17 years ago
Target Milestone: mozilla0.9.4 → mozilla0.9.5

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

17 years ago
Target Milestone: mozilla0.9.6 → Future

Comment 12

17 years ago
-> default owner
Assignee: blaker → sgehani
Status: ASSIGNED → NEW
Product: Browser → Seamonkey
(Reporter)

Comment 13

13 years ago
Wow, this is very old and very invalid now...
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.