Closed Bug 606187 Opened 10 years ago Closed 10 years ago

manual proxy does not forward DNS requests ONLY for secondary account

Categories

(Firefox :: Preferences, defect)

x86_64
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 134105

People

(Reporter: pa.news, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.11) Gecko/20101012 Firefox/3.6.11

Hello, I use Firefox with "manual proxy configuration" localhost, port 9050, SOCKS v5 (no proxy for : localhost, 127.0.0.1).  Port forwarding is achieved with ssh -D9050 user@111.111.111.111 (not the real address).  In my internet configuration, I request a DNS server that is accessible from the proxy but not locally.  Therefore, DNS requests must be forwarded, as well as http requests.  This does work (though slowly, as compared with a local DNS server).

(With "Use system proxy settings" in Firefox, DNS request forwarding does not work at all.  I guess this is a feature, not a bug.)

When I shift to another local account, without changing internet configuration and with exactly the same Firefox configuration, DNS request forwarding does not work any more.  (Though http forwarding still works.)

ssh -D from the second account does not help.

I am certain that Firefox is at least partly responsible for the problem, because Safari (v5.0.2) does work in the same conditions.  

There must be a critical difference between accounts.  Both are admins but the first one is the older.  First account user name is the same as remote machine account user name.

With a fresh new third account (not admin), DNS request forwarding also fails.

Best wishes.

Reproducible: Always

Steps to Reproduce:
1. configure internet to use external DNS (not locally accessible)
2. open tunnel with ssh -D9050 ...
3. configure Firefox to manual proxy, localhost 9050
4. try to open any web site from its name : it won't work
5. try to open any web site from its IP address (e. g. http://193.252.96.3/) : it will work



DNS request forwarding fails for one account (but works for another)
Reporter, what is your setting for http://kb.mozillazine.org/Network.proxy.socks_remote_dns on all accounts?
(In reply to comment #1)
> Reporter, what is your setting for
> http://kb.mozillazine.org/Network.proxy.socks_remote_dns on all accounts?

With the first account, the value of network.proxy.socks_remote_dns 
(checked in about:config) is 

user set   boolean  true

with the second account :

default    boolean false

These values are consistent with observed behaviour.
However, I have configured Firefox identically in both cases.

I do not remember having set network.proxy.socks_remote_dns on first account.  On first account, I have some tools that are not in second account : ChatZilla and Default user agent.
I have installed ChatZilla and Default user agent on the second account as well and network.proxy.socks_remote_dns has not changed, so this was not the problem, sorry for the distraction.

Since the problem is also on the third account, we may conclude that DNS forwarding requires setting on network.proxy.socks_remote_dns.  This should be added to Firefox preferences.

My Firefox version is now 3.6.13.  

Unfortunately, I cannot try DNS forwarding right now in the same conditions as in my message of 2010-10-21.
It seems you (understandably, I feel) you want Firefox to do server-side DNS resolving by default when using a SOCKS proxy, or at least add a UI preference. If so, you might want to resolve this as a duplicate of bug 134105.
Thanks for the link.  Indeed the context is the same but my report is specifically an account dependent.  I am unable to make further tests now.
> I do not remember having set network.proxy.socks_remote_dns on first account. 

Now I remember I activated network.proxy.socks_remote_dns on first account, as advised by Chen Ze in
<a href="https://bugzilla.mozilla.org/show_bug.cgi?id=134105">bug 134105</a>.

I agree that my bug is a duplicate.  I hope that a clear preference will be offered to the user, on where to perform DNS queries.
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 134105
You need to log in before you can comment on or make changes to this bug.