Fennec doesn't load due to not enough vspace (since libload landed)

VERIFIED FIXED in Firefox 4.0

Status

Fennec Graveyard
General
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: willyaranda, Assigned: mwu)

Tracking

({relnote})

Trunk
Firefox 4.0
ARM
Android
relnote

Details

Attachments

(2 attachments, 1 obsolete attachment)

User-Agent:       Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b8pre) Gecko/20101020 Firefox/4.0b8pre
Build Identifier: 

DDMS reports


10-21 16:30:12.873: INFO/ActivityManager(182): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App }
10-21 16:30:13.043: INFO/ActivityManager(182): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=16057 uid=10030 gids={3003, 1015}
10-21 16:30:13.873: INFO/ActivityManager(182): Process com.google.android.apps.maps:LocationFriendService (pid 16011) has died.
10-21 16:30:13.873: INFO/ActivityManager(182): Low Memory: No more background processes.
10-21 16:30:13.883: INFO/GeckoApp(16057): create
10-21 16:30:13.893: INFO/GeckoAppJava(16057): Checking for an update
10-21 16:30:13.963: INFO/global(16057): Default buffer size used in BufferedReader constructor. It would be better to be explicit if an 8k-char buffer is required.
10-21 16:30:14.023: INFO/GeckoApp(16057): env0: null
10-21 16:30:14.033: ERROR/GeckoLibLoad(16057): Couldn't load lib/libmozalloc.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libmozalloc.so'. no vspace available.
10-21 16:30:14.043: ERROR/GeckoLibLoad(16057): Couldn't load lib/libnspr4.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libnspr4.so'. no vspace available.
10-21 16:30:14.043: ERROR/GeckoLibLoad(16057): Couldn't load lib/libplc4.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libplc4.so'. no vspace available.
10-21 16:30:14.043: ERROR/GeckoLibLoad(16057): Couldn't load lib/libplds4.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libplds4.so'. no vspace available.
10-21 16:30:14.073: ERROR/GeckoLibLoad(16057): Couldn't load lib/libmozsqlite3.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libmozsqlite3.so'. no vspace available.
10-21 16:30:14.083: ERROR/GeckoLibLoad(16057): Couldn't load lib/libnssutil3.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libnssutil3.so'. no vspace available.
10-21 16:30:14.123: ERROR/GeckoLibLoad(16057): Couldn't load lib/libnss3.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libnss3.so'. no vspace available.
10-21 16:30:14.133: ERROR/GeckoLibLoad(16057): Couldn't load lib/libssl3.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libssl3.so'. no vspace available.
10-21 16:30:14.133: ERROR/GeckoLibLoad(16057): Couldn't load lib/libsmime3.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libsmime3.so'. no vspace available.
10-21 16:30:17.643: ERROR/GeckoLibLoad(16057): Couldn't load lib/libxul.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libxul.so'. no vspace available.
10-21 16:30:17.713: ERROR/GeckoLibLoad(16057): Couldn't load lib/libxpcom.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libxpcom.so'. no vspace available.
10-21 16:30:17.753: ERROR/GeckoLibLoad(16057): Couldn't load lib/libnssckbi.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libnssckbi.so'. no vspace available.
10-21 16:30:17.793: ERROR/GeckoLibLoad(16057): Couldn't load lib/libfreebl3.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libfreebl3.so'. no vspace available.
10-21 16:30:17.803: ERROR/GeckoLibLoad(16057): Couldn't load lib/libsoftokn3.so because Cannot load library: alloc_mem_region[879]: OOPS: 16057 cannot map library 'libsoftokn3.so'. no vspace available.
10-21 16:30:17.803: ERROR/GeckoLibLoad(16057): Couldn't get a handle to libxul!
10-21 16:30:18.083: INFO/GeckoAppJava(16057): installing extension : extensions/feedback@mobile.mozilla.org.xpi
10-21 16:30:18.103: INFO/DEBUG(61): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
10-21 16:30:18.103: INFO/DEBUG(61): Build fingerprint: 'google/passion/passion/mahimahi:2.2/FRF91/43546:user/release-keys'
10-21 16:30:18.103: INFO/DEBUG(61): pid: 16057, tid: 16057  >>> org.mozilla.fennec <<<
10-21 16:30:18.103: INFO/DEBUG(61): signal 11 (SIGSEGV), fault addr 00000000
10-21 16:30:18.103: INFO/DEBUG(61):  r0 0000aa50  r1 30de38e0  r2 00008a5c  r3 00000000
10-21 16:30:18.103: INFO/DEBUG(61):  r4 7ed83520  r5 00000000  r6 30de38e0  r7 2cb36c48
10-21 16:30:18.103: INFO/DEBUG(61):  r8 7ed83500  r9 2cb36c40  10 2cb36c2c  fp 30e40d78
10-21 16:30:18.103: INFO/DEBUG(61):  ip 4ee044b5  sp 7ed834f8  lr 4ee044c5  pc 00000000  cpsr 00000010
10-21 16:30:18.103: INFO/DEBUG(61):  d0  6e4965766974616e  d1  472f6f6b63656765
10-21 16:30:18.103: INFO/DEBUG(61):  d2  000000000000006c  d3  000000000000006c
10-21 16:30:18.103: INFO/DEBUG(61):  d4  736e6f69736e6574  d5  636162646565662f
10-21 16:30:18.103: INFO/DEBUG(61):  d6  656c69626f6d406b  d7  616c6c697a6f6d2e
10-21 16:30:18.103: INFO/DEBUG(61):  d8  0000000000000000  d9  0000000000000000
10-21 16:30:18.103: INFO/DEBUG(61):  d10 0000000000000000  d11 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d12 0000000000000000  d13 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d14 0000000000000000  d15 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d16 a328bf2b30e40180  d17 bff0000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d18 3ff0000000000000  d19 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d20 0000000000000000  d21 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d22 3ff0000000000000  d23 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d24 3ff0000000000000  d25 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d26 0000000000000000  d27 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d28 0000000000000000  d29 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  d30 0000000000000000  d31 0000000000000000
10-21 16:30:18.113: INFO/DEBUG(61):  scr 80000012
10-21 16:30:18.643: INFO/DEBUG(61):          #00  pc 00000000  
10-21 16:30:18.643: INFO/DEBUG(61):          #01  lr 4ee044c5  /data/data/org.mozilla.fennec/lib/libmozutils.so
10-21 16:30:18.643: INFO/DEBUG(61): code around pc:
10-21 16:30:18.643: INFO/DEBUG(61): code around lr:
10-21 16:30:18.643: INFO/DEBUG(61): 4ee044a4 46294620 f8d34632 479832a8 bf00bd70 
10-21 16:30:18.653: INFO/DEBUG(61): 4ee044b4 bf004b04 b510a200 4a03189b 4798589b 
10-21 16:30:18.653: INFO/DEBUG(61): 4ee044c4 bf00bd10 000054b8 00008a5c bf004b05 
10-21 16:30:18.653: INFO/DEBUG(61): 4ee044d4 0c00f20f 4463b510 c00cf8df 685b4463 
10-21 16:30:18.653: INFO/DEBUG(61): 4ee044e4 bd104798 0000549c 00008a5c bf004b05 
10-21 16:30:18.653: INFO/DEBUG(61): stack:
10-21 16:30:18.653: INFO/DEBUG(61):     7ed834b8  2cb36c2c  
10-21 16:30:18.653: INFO/DEBUG(61):     7ed834bc  6fd0be1d  /system/lib/libc.so
10-21 16:30:18.653: INFO/DEBUG(61):     7ed834c0  0011ebe8  [heap]
10-21 16:30:18.653: INFO/DEBUG(61):     7ed834c4  00122128  [heap]
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834c8  0000140c  
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834cc  0000ccc8  [heap]
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834d0  2cb36c2c  
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834d4  0011ebe8  [heap]
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834d8  00000000  
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834dc  00000000  
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834e0  00122128  [heap]
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834e4  6fd0cd65  /system/lib/libc.so
10-21 16:30:18.663: INFO/DEBUG(61):     7ed834e8  0011ebe8  [heap]
10-21 16:30:18.673: INFO/DEBUG(61):     7ed834ec  6ca41a6b  /system/lib/libdvm.so
10-21 16:30:18.673: INFO/DEBUG(61):     7ed834f0  df002777  
10-21 16:30:18.673: INFO/DEBUG(61):     7ed834f4  e3a070ad  
10-21 16:30:18.673: INFO/DEBUG(61): #00 7ed834f8  7ed83520  [stack]
10-21 16:30:18.673: INFO/DEBUG(61):     7ed834fc  6ca10d78  /system/lib/libdvm.so
10-21 16:30:18.673: INFO/DEBUG(61):     7ed83500  0000ccc8  [heap]
10-21 16:30:18.673: INFO/DEBUG(61):     7ed83504  2cd4b768  /dev/ashmem/dalvik-LinearAlloc (deleted)
10-21 16:30:18.673: INFO/DEBUG(61):     7ed83508  30de38e0  /dev/ashmem/mspace/dalvik-heap/2 (deleted)
10-21 16:30:18.683: INFO/DEBUG(61):     7ed8350c  2cb36c40  
10-21 16:30:18.683: INFO/DEBUG(61):     7ed83510  6ca10f40  /system/lib/libdvm.so
10-21 16:30:18.683: INFO/DEBUG(61):     7ed83514  0000ccc8  [heap]
10-21 16:30:18.683: INFO/DEBUG(61):     7ed83518  7ed83520  [stack]
10-21 16:30:18.683: INFO/DEBUG(61):     7ed8351c  6ca3c827  /system/lib/libdvm.so
10-21 16:30:18.683: INFO/DEBUG(61):     7ed83520  2cb36c40  
10-21 16:30:18.683: INFO/DEBUG(61):     7ed83524  2ee585af  /data/dalvik-cache/mnt@asec@org.mozilla.fennec-1@pkg.apk@classes.dex
10-21 16:30:18.693: INFO/DEBUG(61):     7ed83528  4ee044b5  /data/data/org.mozilla.fennec/lib/libmozutils.so
10-21 16:30:18.693: INFO/DEBUG(61):     7ed8352c  7ed835d0  [stack]
10-21 16:30:18.693: INFO/DEBUG(61):     7ed83530  7ed835d0  [stack]
10-21 16:30:18.693: INFO/DEBUG(61):     7ed83534  00000001  
10-21 16:30:18.693: INFO/DEBUG(61):     7ed83538  00000000  
10-21 16:30:18.693: INFO/DEBUG(61):     7ed8353c  2cd4b768  /dev/ashmem/dalvik-LinearAlloc (deleted)
10-21 16:30:20.533: INFO/ActivityManager(182): Process org.mozilla.fennec (pid 16057) has died.
10-21 16:30:20.533: INFO/WindowManager(182): WIN DEATH: Window{310b3e10 org.mozilla.fennec/org.mozilla.fennec.App paused=false}


Reproducible: Always




Using a custom Froyo leak+ROM in Acer Liquid (not E, so 256MB RAM)
Worked correctly before the landing of libload.
I've tested both SD and internal memory. Same error.
OS: Mac OS X → Android
Hardware: x86 → ARM
To narrow down the problem:

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2010-10-15-04-mozilla-central-android-r7/ works (20101015040843 19cb42fa4554)

http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/2010-10-16-04-mozilla-central-android-r7/ doesn't work (20101016040616 397c458b40a4)

The pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=19cb42fa4554&tochange=397c458b40a4

in that range, there is bug 588607
the current nightly builds have crash reporter built in. Can you link to a crash report?
(Assignee)

Comment 4

7 years ago
(In reply to comment #3)
> the current nightly builds have crash reporter built in. Can you link to a
> crash report?

Crash report won't help for this. This failure occurs before crash reporter is even initialized. Fortunately, the logcat out lets us know roughly what went wrong.
(Assignee)

Comment 5

7 years ago
Try hooking up your phone (with usb debugging one) and running this command (all in one line, hopefully adb is in your path):

adb shell am start -a org.mozilla.gecko.DEBUG -n org.mozilla.fennec/org.mozilla.fennec.App

This should bring things up in debug mode. You should see a large Launch button. Once you see this, run:

adb shell cat "/proc/`adb shell ps | grep org.mozilla.fennec | head -n 1 | cut -c11-16 | tr -d \ `/maps"

Can you give me the output of that line? It may be a lot - feel free to attach it to this bug. If you need help with this and use IRC, I'm mwu on #mobile
I've created a thread in the biggest Acer Liquid community and I got 2 reports. It crashes with latest Froyo system (It's a leak, but anyway…)

http://android.modaco.com/content/acer-liquid-liquid-modaco-com/321010/could-you-test-firefox-mobile-in-your-device/
(Assignee)

Comment 7

7 years ago
Can we get some reports from a stock firmware? (assuming there is one running 2.0 or 2.1)
I'll try over the weekend to test it on a 2.1 stock and 2.2 stock.
Trying with latest 2.1 official ROM (2.100.27_EMEA_CUS1) crashes too.
Flashed a CyanogenMod bin (6.1.0pre, 1month old) works perfectly on top of latest 2.1 official ROM.

Any hint?
(Assignee)

Comment 11

7 years ago
Cyangenmod is likely to be building their libraries at the normal addresses instead of what acer is doing.

Either way I think we should have proper fallbacks for devices with weird address space layouts.
Assignee: nobody → mwu
Status: UNCONFIRMED → NEW
tracking-fennec: --- → ?
Ever confirmed: true
The latest nightlies crashes with different problem: should I file another bug?

11-11 00:36:53.046: ERROR/GeckoLibLoad(4429): Couldn't get an ashmem buffer
11-11 00:36:53.046: ERROR/GeckoLibLoad(4429): Couldn't get a handle to libxul!
(Assignee)

Comment 13

7 years ago
(In reply to comment #12)
> The latest nightlies crashes with different problem: should I file another bug?
> 
> 11-11 00:36:53.046: ERROR/GeckoLibLoad(4429): Couldn't get an ashmem buffer
> 11-11 00:36:53.046: ERROR/GeckoLibLoad(4429): Couldn't get a handle to libxul!

Yeah, that's a different problem.. very odd. Please file another bug for that.

Did that start happening right after bug 607534 landed?

I've seen that issue but only on an archos 5 tablet hacked to run froyo.
Keywords: relnote
So filled bug 611163
Keywords: relnote
Keywords: relnote
tracking-fennec: ? → 2.0+

Comment 15

7 years ago
This thread contains base address required for the Acer Liquid E stock ROMs: http://android.modaco.com/content/acer-liquid-liquid-modaco-com/309721/did-anyone-successfully-built-android-from-sources/

Can someone provide us with the knowledge required to compile Mozilla Fennec ourselves with the new base addresses specific for our build?

Comment 16

7 years ago
Specifically, Acer does:  
libc.so                 0x6fe00000
libdvm.so               0x6d000000

HTC and Motorola both do: 
libc.so                 0xAFE00000
libdvm.so               0xAD000000
(Assignee)

Comment 17

7 years ago
Created attachment 497405 [details] [diff] [review]
Use mmap given addresses if necessary

This patch lets us fall back to using the addresses that mmap gives us if trying to mmap a specific address fails. The use of specific addresses is disabled after any collision since we can still mess up other libraries if we're mapping into random regions used by the system linker.
Attachment #497405 - Flags: review?(tglek)

Comment 18

7 years ago
Comment on attachment 497405 [details] [diff] [review]
Use mmap given addresses if necessary

wrong patch?
(Assignee)

Comment 19

7 years ago
Created attachment 497421 [details] [diff] [review]
Use mmap given addresses if necessary (right patch)

Odd. Don't know how that happened.
Attachment #497405 - Attachment is obsolete: true
Attachment #497421 - Flags: review?(tglek)
Attachment #497405 - Flags: review?(tglek)

Comment 20

7 years ago
Comment on attachment 497421 [details] [diff] [review]
Use mmap given addresses if necessary (right patch)

># HG changeset patch
># Parent 300c3b8fab7947ffe8c9eb384782d21930710baa
>
>diff --git a/other-licenses/android/linker.c b/other-licenses/android/linker.c
>--- a/other-licenses/android/linker.c
>+++ b/other-licenses/android/linker.c
>@@ -828,6 +828,11 @@ get_lib_extents(int fd, const char *name
> 
> static int reserve_mem_region(soinfo *si)
> {
>+#ifdef MOZ_LINKER
>+    static int mapping_collision = 0;
>+    if (mapping_collision)
>+        si->base = NULL;
>+#endif

I don't understand what setting si->base accomplishes. According to docs it's just a hint to mmap, so it wouldn't change the outcome syscall below(ie if kernel can't create a mapping at that address).

>     void *base = mmap((void *)si->base, si->size, PROT_READ | PROT_EXEC,
>                       MAP_PRIVATE | MAP_ANONYMOUS, -1, 0);
>     if (base == MAP_FAILED) {

unless there is some logic below that is changed.

>@@ -837,11 +842,16 @@ static int reserve_mem_region(soinfo *si
>               errno, strerror(errno));
>         return -1;
>     } else if (base != (void *)si->base) {
>+#ifdef MOZ_LINKER
>+        mapping_collision = 1;
>+        si->base = base;
>+#else

I guess reserve_mem_region has some sort of retry logic?
Attachment #497421 - Flags: review?(tglek)
(Assignee)

Comment 21

7 years ago
(In reply to comment #20)
> > static int reserve_mem_region(soinfo *si)
> > {
> >+#ifdef MOZ_LINKER
> >+    static int mapping_collision = 0;
> >+    if (mapping_collision)
> >+        si->base = NULL;
> >+#endif
> 
> I don't understand what setting si->base accomplishes. According to docs it's
> just a hint to mmap, so it wouldn't change the outcome syscall below(ie if
> kernel can't create a mapping at that address).
> 

Setting si->base to null tells mmap to pick an address itself. If we've failed to pick an address before, subsequent base address selections should be done by mmap since the ba.c may end up accidentally stealing address space from the system loader. I've also seen problems with allocating regions from the range of addresses that the system loader uses, so that's why this is here.

> >     void *base = mmap((void *)si->base, si->size, PROT_READ | PROT_EXEC,
> >                       MAP_PRIVATE | MAP_ANONYMOUS, -1, 0);
> >     if (base == MAP_FAILED) {
> 
> unless there is some logic below that is changed.
> 
> >@@ -837,11 +842,16 @@ static int reserve_mem_region(soinfo *si
> >               errno, strerror(errno));
> >         return -1;
> >     } else if (base != (void *)si->base) {
> >+#ifdef MOZ_LINKER
> >+        mapping_collision = 1;
> >+        si->base = base;
> >+#else
> 
> I guess reserve_mem_region has some sort of retry logic?

Since we aren't passing MAP_FIXED to mmap, mmap will give us a different address if the requested address can't be used. The retry logic is sorta built into mmap. We can't actually use MAP_FIXED because that tries very hard to give you the address you requested and will unmap other mappings to achieve this.
(Assignee)

Comment 22

7 years ago
I've put up a build at http://people.mozilla.com/~mwu/fennec-4.0b3pre.en-US.eabi-arm.apk with this patch. If someone with an acer device (and acer firmware) can try this and report whether it works or not, it would help a bunch since nobody over here has an acer liquid.

Comment 23

7 years ago
Tested the build at http://people.mozilla.com/~mwu/fennec-4.0b3pre.en-US.eabi-arm.apk

No crashes on Acer Liquid E
Custom firmware with base Acer Froyo build 4.504b.00
LCR-1.1.2 unmodified libraries

Will cross post for more tests
I don't have my Liquid working anymore, so @chision if you could post this in Modaco forum and request a couple of more tests?

Thanks!

Comment 25

7 years ago
Does not work with Acer Liquid + LCR 1.8.22 (Eclair), using App2SD. 

Closes immediately at start after white screen.
From different reports, it seems that Fennec is working fine in LiquidE (512 RAM) and not in Liquid (256 RAM).

Another report from Liquid (256):

I/ActivityManager(  111): Starting activity: Intent { act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App }
I/ActivityManager(  111): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=1073 uid=10067 gids={3003, 1015}
I/GeckoApp( 1073): create
I/wpa_supplicant(  182): WPS-AP-AVAILABLE 
V/WifiMonitor(  111): Event [WPS-AP-AVAILABLE ]
I/GeckoAppJava( 1073): Checking for an update
D/dalvikvm( 1073): Trying to load lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x460be398
D/dalvikvm( 1073): Added shared lib /data/data/org.mozilla.fennec/lib/libmozutils.so 0x460be398
D/dalvikvm( 1073): No JNI_OnLoad found in /data/data/org.mozilla.fennec/lib/libmozutils.so 0x460be398, skipping init
I/GeckoApp( 1073): env0: null
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get an ashmem buffer
E/GeckoLibLoad( 1073): Couldn't get a handle to libxul!
I/GeckoApp( 1073): start
I/GeckoApp( 1073): resume
D/dalvikvm( 1073): GC_FOR_MALLOC freed 2079 objects / 154464 bytes in 44ms
I/GeckoAppJava( 1073): installing extension : extensions/feedback@mobile.mozilla.org.xpi
I/DEBUG   (   62): *** *** *** *** *** *** *** *** *** *** *** *** *** *** *** ***
I/DEBUG   (   62): Build fingerprint: 'google/passion/passion/mahimahi:2.2.1/FRG83/60505:user/release-keys'
I/DEBUG   (   62): pid: 1073, tid: 1073  >>> org.mozilla.fennec <<<
I/DEBUG   (   62): signal 11 (SIGSEGV), fault addr 00000000
I/DEBUG   (   62):  r0 0000aa48  r1 46124cd0  r2 00008a6c  r3 00000000
I/DEBUG   (   62):  r4 bebae468  r5 00000000  r6 46124cd0  r7 4208bc24
I/DEBUG   (   62):  r8 bebae448  r9 4208bc1c  10 4208bc08  fp bebae7b8
I/DEBUG   (   62):  ip 8080465d  sp bebae440  lr 8080466f  pc 00000000  cpsr 80000010
I/DEBUG   (   62): cannot get registers: I/O error
I/DEBUG   (   62):          #00  pc 00000000  
I/DEBUG   (   62):          #01  lr 8080466f  /data/data/org.mozilla.fennec/lib/libmozutils.so
I/DEBUG   (   62): 
I/DEBUG   (   62): code around pc:
I/DEBUG   (   62): 
I/DEBUG   (   62): code around lr:
I/DEBUG   (   62): 8080464c 58984a02 bf004770 00005628 00008a6c 
I/DEBUG   (   62): 8080465c bf004b04 b510a200 4a03189b 685b189b 
I/DEBUG   (   62): 8080466c bd104798 00005610 00008a6c bf004b05 
I/DEBUG   (   62): 8080467c 0c00f20f 4463b510 c00cf8df 689b4463 
I/DEBUG   (   62): 8080468c bd104798 000055f4 00008a6c bf004b05 
I/DEBUG   (   62): 
I/DEBUG   (   62): stack:
I/DEBUG   (   62):     bebae400  4208bc08  
I/DEBUG   (   62):     bebae404  afd0c04d  /system/lib/libc.so
I/DEBUG   (   62):     bebae408  aca04240  /system/lib/libdvm.so
I/DEBUG   (   62):     bebae40c  0000cd58  [heap]
I/DEBUG   (   62):     bebae410  00001418  
I/DEBUG   (   62):     bebae414  b0003587  /system/bin/linker
I/DEBUG   (   62):     bebae418  b0015954  
I/DEBUG   (   62):     bebae41c  00235100  [heap]
I/DEBUG   (   62):     bebae420  00000000  
I/DEBUG   (   62):     bebae424  00000000  
I/DEBUG   (   62):     bebae428  002350c8  [heap]
I/DEBUG   (   62):     bebae42c  afd0cf99  /system/lib/libc.so
I/DEBUG   (   62):     bebae430  00235100  [heap]
I/DEBUG   (   62):     bebae434  aca38483  /system/lib/libdvm.so
I/DEBUG   (   62):     bebae438  df002777  
I/DEBUG   (   62):     bebae43c  e3a070ad  
I/DEBUG   (   62): #00 bebae440  bebae468  [stack]
I/DEBUG   (   62):     bebae444  aca04078  /system/lib/libdvm.so
I/DEBUG   (   62):     bebae448  0000cd58  [heap]
I/DEBUG   (   62):     bebae44c  422a05ec  /dalvik-LinearAlloc (deleted)
I/DEBUG   (   62):     bebae450  46124cd0  /mspace/dalvik-heap/2 (deleted)
I/DEBUG   (   62):     bebae454  4208bc1c  
I/DEBUG   (   62):     bebae458  aca04240  /system/lib/libdvm.so
I/DEBUG   (   62):     bebae45c  0000cd58  [heap]
I/DEBUG   (   62):     bebae460  bebae468  [stack]
I/DEBUG   (   62):     bebae464  aca32dd3  /system/lib/libdvm.so
I/DEBUG   (   62):     bebae468  4208bc1c  
I/DEBUG   (   62):     bebae46c  439d7bf7  /cache/dalvik-cache/data@app@org.mozilla.fennec-1.apk@classes.dex
I/DEBUG   (   62):     bebae470  8080465d  /data/data/org.mozilla.fennec/lib/libmozutils.so
I/DEBUG   (   62):     bebae474  bebae518  [stack]
I/DEBUG   (   62):     bebae478  bebae518  [stack]
I/DEBUG   (   62):     bebae47c  00000001  
I/DEBUG   (   62):     bebae480  00000000  
I/DEBUG   (   62):     bebae484  422a05ec  /dalvik-LinearAlloc (deleted)
I/ActivityManager(  111): Process org.mozilla.fennec (pid 1073) has died.
(Assignee)

Updated

7 years ago
Attachment #497421 - Flags: review?(tglek)

Comment 27

7 years ago
Comment on attachment 497421 [details] [diff] [review]
Use mmap given addresses if necessary (right patch)

yuck
Attachment #497421 - Flags: review?(tglek) → review+

Comment 28

7 years ago
Tested the build at
http://people.mozilla.com/~mwu/fennec-4.0b3pre.en-US.eabi-arm.apk

on Acer Liquid, running Android 2.2 FroYo, ROM build Acer_LiquidE_4.004.04_PA_FIDO. 

This build runs fine, but the latest Fennec build 4.0b4 crashes and will not start. BTW, this build of Fennec runs fine whether installed on the phone or on the SD card with App2SD.
(Assignee)

Comment 29

7 years ago
Created attachment 509298 [details] [diff] [review]
hg patch ready patch
(Assignee)

Updated

7 years ago
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/d62ae33c94d7
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → fennec2.0

Comment 31

7 years ago
It still does crash on my liquid.
Guillermo López, can you verify if this is fixed now on the latest nightly builds?
I don't have a working Acer Liquid right now, someone cc'd here could test it?

(Sorry!)
(Assignee)

Comment 34

6 years ago
(In reply to comment #33)
> I don't have a working Acer Liquid right now, someone cc'd here could test it?
> 
> (Sorry!)

Acer Liquid is not expected to work due to bug 611163. Acer Liquid E's however, should work. This bug should be verified on the Acer Liquid E.
(Assignee)

Comment 35

6 years ago
(In reply to comment #34)
> (In reply to comment #33)
> > I don't have a working Acer Liquid right now, someone cc'd here could test it?
> > 
> > (Sorry!)
> 
> Acer Liquid is not expected to work due to bug 611163. Acer Liquid E's however,
> should work. This bug should be verified on the Acer Liquid E.

Oh, bug 611163 is suppose to be fixed. If someone has a Acer Liquid and it doesn't work, reopen bug 611163.

Comment 36

6 years ago
Just ran it on mine... W00T 
It works! 
You guys are awesome!
(Assignee)

Comment 37

6 years ago
(In reply to comment #36)
> Just ran it on mine... W00T 
> It works! 
> You guys are awesome!

Acer Liquid or Acer Liquid E?
can you also specify the buildID you verified it on?  thanks!

Comment 39

6 years ago
sorry.
yes - its the liquid E with froyo running.
kernel - 2.6.29
build number - acer_liquid_4.002.08_EMEA_GEN1
baseband - A1-05.01.05

It was originally a fido(canadian) phone.. Now i have a generic European ROM on it. 

Also a2sd works !
I'm going to play around with it a little bit. Will keep this place posted !
:D
Thanks again - finally ff sync !

Comment 40

6 years ago
"Works" on Acer liquid with Android 2.2 firmware (LCR 2.0). 

However, startup takes more than a minute and while fennec is running the phone becomes extremely laggy. Lag is so bad android suggests after every "keypress" the application is crashed because it's unresponsive. This applies to other apps, I saw it going to app management to forceclose fennec.. 

So, yeah, Fennec *starts* but it's completely useless on Liquid.

Comment 41

6 years ago
@Olli Männistö: Your comments may apply to Acer Liquid, but not to Acer Liquid E. I find that Fennec starts in about 10 seconds, and pages load at a reasonable speed.  I'm running Android 2.2 as well.

Comment 42

6 years ago
Tried nightly build 6. Improves loading speed to about 3 seconds. Although when I tried beta 5, it didn't take more than 5-6 secs. Although, it doesn't seem to register new line (enter - next line) in text entry. It recognizes it as a single space. I'm using swype. Don't have this issue elsewhere.
Running stock acer froyo EMEA_GEN1 on liquid e. No other issues noticed.

Comment 43

6 years ago
Liquid E has 512MB ram and has other differences from original Liquid A1. Michael Wu was asking if it works OK with original liquid. It doesn't. OK, I suppose the crash-at-startup is fixed but otherwise I'd file it under "does not work properly". I'm running App2SD in case Fennec has issues with it.

Comment 44

6 years ago
(In reply to comment #43)
It wasn't loading on liquid e before this. And App2sd works great. 160KB on phone. That's amazing considering how much other simpler apps take.
FF however does take a lot of ram. I have noticed 60 MB so far.
based on comment 39, comment 40 marking as verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.