Enable n900 unittest/talos results on TryServer

RESOLVED FIXED

Status

Release Engineering
General
P4
normal
RESOLVED FIXED
7 years ago
4 years ago

People

(Reporter: joduinn, Assigned: jhford)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 2 obsolete attachments)

Blocked on getting additional phones online, to handle the load.
Depends on: 606607
Created attachment 488565 [details] [diff] [review]
buildbot-configs v1

This patch adds the try server branch.  This branch doesn't allow merging of builds and doesn't have any polling.
Assignee: nobody → jhford
Status: NEW → ASSIGNED
Attachment #488565 - Flags: review?(aki)
Comment on attachment 488565 [details] [diff] [review]
buildbot-configs v1

Hm, does your .hgrc contain

[diff]
git=true
showfunc = 1
unified = 9

?

r=me if s,try_mode,enable_try,g
Attachment #488565 - Flags: review?(aki) → review+
[diff]
git=True
showfunc=True

i will land with that change
(I had to apply the patch to see context for

@@ -107,6 +107,7 @@ for branch_name in sorted(BRANCHES.keys(
                 'slavebuilddir': '/builds/slave_build_dir',
                 'factory': talos_factory,
                 'category': bb_branch,
+                'mergeRequests': not branch.get('try_mode', False),

; that would have been fixed by unified = 9.)
Created attachment 488582 [details] [diff] [review]
buildbotcustom v1

this patch adds a sendchange to the n900-gtk builds.
Created attachment 488589 [details] [diff] [review]
buildbotcustom

minor typo.
Attachment #488582 - Attachment is obsolete: true
Attachment #488589 - Attachment description: buildbot-configs v2 → buildbotcustom
Created attachment 488966 [details] [diff] [review]
buildbotcustom v2

works on a staging try server,
Attachment #488589 - Attachment is obsolete: true
Attachment #488966 - Flags: review?(aki)
Comment on attachment 488966 [details] [diff] [review]
buildbotcustom v2

This is pretty ugly, but is a workable solution until we get make upload working for maemo.

To sum up our discussion, the long term goals are:

* make upload for maemo, with appropriate sendchanges as everything else (blocked by multilocale)
* either get the n900s on an existing 08x test master that is already part of the sendchange list, or add pmm/smm to a config list of sendchange hosts
* maemo tests -> mozilla-tests/

and the short term followup bugs are:

* mail notification for maemo try tests

r=me to get this working asap without blocking on the above.
Attachment #488966 - Flags: review?(aki) → review+
Blocks: 610574
Comment on attachment 488565 [details] [diff] [review]
buildbot-configs v1

http://hg.mozilla.org/build/buildbot-configs/rev/fbc1542e993f
Attachment #488565 - Flags: checked-in+
Comment on attachment 488966 [details] [diff] [review]
buildbotcustom v2

http://hg.mozilla.org/build/buildbotcustom/rev/25fae1f9a41e
Attachment #488966 - Flags: checked-in+
Created attachment 489361 [details] [diff] [review]
send email

this patch adds the ability to send email on for n900s on try.  We should probably make sure that only known-good tests are enabled otherwise we will mail-bomb try users.
Attachment #489361 - Flags: review?(aki)
Created attachment 489367 [details] [diff] [review]
only run green tests on tryserver

This patch removes broken tests from the test suites to run on mozilla central.

Verified that the code only shows working suites by adding 

print 'Running these things for tryserver:'
print '\n'.join(
          BRANCHES['tryserver']['platforms']['n900-gtk']['test_suites'].keys() +
          BRANCHES['tryserver']['platforms']['n900-gtk']['talos_suites'].keys()
)

to the end of the config-production-n900.py file.  I got the output:

Running these things for tryserver:
tpan
twinopen
tsspider
ts
tsvg
tgfx
tdhtml

I need to run this in staging.  Ugly patch though.
Attachment #489361 - Flags: review?(aki) → review+
Duplicate of this bug: 610574
Comment on attachment 489367 [details] [diff] [review]
only run green tests on tryserver

works in staging.
Attachment #489367 - Flags: review?(aki)
Comment on attachment 489367 [details] [diff] [review]
only run green tests on tryserver

That looks right.
Attachment #489367 - Flags: review?(aki) → review+
Comment on attachment 489361 [details] [diff] [review]
send email

http://hg.mozilla.org/build/buildbot-configs/rev/2196e8c24b97
Attachment #489361 - Flags: checked-in+
Comment on attachment 489367 [details] [diff] [review]
only run green tests on tryserver

https://bugzilla.mozilla.org/show_bug.cgi?id=606310
Attachment #489367 - Flags: checked-in+
all done here
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.