Closed Bug 606342 Opened 12 years ago Closed 12 years ago

Load additional tweets when user scrolls to bottom of page

Categories

(support.mozilla.org :: Army of Awesome, task)

task
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: williamr, Assigned: wenzel)

References

()

Details

Add infinite scrolling functionality to the tweet list. Similar to twitter.com, trigger an AJAX request when a user is near the bottom of the page that appends additional tweets to end of list.

Tweets are retrieved from database and once all tweets are retrieved, no more requests are made and no message is displayed.

My understanding is that we only store the 500 most recent tweets in our database. Can someone verify? Maybe Fred? Want to make sure there's a limit on how many tweets we show.

There's a jQuery plugin that might be helpful for this:
http://www.infinite-scroll.com/infinite-scroll-jquery-plugin/
Assignee: malexis → fwenzel
(In reply to comment #0)
> My understanding is that we only store the 500 most recent tweets in our
> database. Can someone verify? Maybe Fred? Want to make sure there's a limit on
> how many tweets we show.

Yes, that's the current limit.
I've got some code ready that should do precisely what you comment 0 asks for:
http://github.com/fwenzel/kitsune/compare/606342-scroll-tweets

I already pinged jsocol with an r? .

QA / William: When this lands on staging, please make sure the footer is still reasonably reachable. My worry is that once you scroll to the end, the infinite scrolling will push the footer out of the viewport again, causing you to scroll down further, which will once again trigger an extension of the tweet list (etc.). If that's an issue, perhaps we have to get a little more creative :)
Status: NEW → ASSIGNED
Landed this on master:
http://github.com/jsocol/kitsune/commit/ce9fafc

... and merged into 2.2.x:
http://github.com/jsocol/kitsune/commit/f686ce0

Please file enhancement bugs if something needs tweaked, or reopen if anything major is broken.
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Reopening since this feature isn't working on stage right now due to bug 608317. Will close this again once that's fixed.
Status: RESOLVED → REOPENED
Depends on: 608317
Resolution: FIXED → ---
Wfm on stage, please test again.
Status: REOPENED → RESOLVED
Closed: 12 years ago12 years ago
Resolution: --- → FIXED
I just checked out support-stage.mozilla.com and it scrolls to 140 tweets- is that the maximum set or is there another condition applied to what displays?
I just checked out support-stage.mozilla.com and it scrolls to 140 tweets- is that the maximum set or is there another condition applied to what displays?
It only displays English tweets, which might be related (though 360/500 tweets in non-English seems high).
I just tried twice and got 220 and 260 tweets after scrolling.

Can anyone reproduce showing a max of 140 tweets?
I just tried another browser and got 230- but whether it's 140/220/260 that's still far below the 500 limit.
I'm okay with maxing out at ~200 tweets. Curious if we can reproduce the 140.

@Fred: of the 500 recent tweets we store in the database, do they all meet our filters? or have they not been filtered yet?
(In reply to comment #11)
> @Fred: of the 500 recent tweets we store in the database, do they all meet our
> filters? or have they not been filtered yet?

They meet all the filters except language. For displaying, Alex filtered out the non-English ones.
Marking this as verified. I'll keep an eye out to see if the shorter list repros, but I can't do it for the time being.
Status: RESOLVED → VERIFIED
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.