Closed Bug 606366 Opened 10 years ago Closed 10 years ago

Port to SM Remove .wrappedJSObject gets that don't work with the new wrappers

Categories

(SeaMonkey :: Session Restore, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.1b2

People

(Reporter: iann_bugzilla, Assigned: iann_bugzilla)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

http://hg.mozilla.org/mozilla-central/rev/574b0fb35604 fixed issues on m-c for certain tests that didn't work with the new wrappers, we should do the same for browser_393716.js and browser_bug510890.js
Patch that ports the fix.
Attachment #485186 - Flags: review?(neil)
Depends on: 580128
Attachment #485186 - Flags: review?(neil) → review+
Comment on attachment 485186 [details] [diff] [review]
Patch to remove broken wrapper v0.1 [Checked in: Comment 2]

http://hg.mozilla.org/comm-central/rev/04465db8a913
Attachment #485186 - Attachment description: Patch to remove broken wrapper v0.1 → Patch to remove broken wrapper v0.1 [Checked in: Comment 2]
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Component: Testing Infrastructure → Session Restore
QA Contact: testing-infrastructure → session.restore
This patch fixes up the session core code too.
Attachment #485500 - Flags: review?(neil)
(In reply to comment #3)
> Created attachment 485500 [details] [diff] [review]
> Let's fix the session core code too
> 
> This patch fixes up the session core code too.

Ported from m-c changeset http://hg.mozilla.org/mozilla-central/rev/956791edd7be
Attachment #485500 - Flags: review?(neil) → review?(misak.bugzilla)
(In reply to comment #4)
> (In reply to comment #3)
> > Created attachment 485500 [details] [diff] [review] [details]
> > Let's fix the session core code too
> > 
> > This patch fixes up the session core code too.
> 
> Ported from m-c changeset
> http://hg.mozilla.org/mozilla-central/rev/956791edd7be

For some reason this fixes the two broken tests but breaks browser_339445.js test :(
Comment on attachment 485500 [details] [diff] [review]
Let's fix the session core code too [Checked in: Comment 9]

This one turned out to be easier to reproduce than I expected, since session store based undo close tab of about:config is completely broken without this.
Attachment #485500 - Flags: review?(misak.bugzilla) → review+
(In reply to comment #5)
> For some reason this fixes the two broken tests but breaks browser_339445.js
> test :(
Sorry I didn't see this. (But I have no idea why it might affect that test.)
(In reply to comment #5)
> For some reason this fixes the two broken tests but breaks browser_339445.js
> test :(
That test passes locally for me with or without the patch.
Comment on attachment 485500 [details] [diff] [review]
Let's fix the session core code too [Checked in: Comment 9]

http://hg.mozilla.org/comm-central/rev/13f39f4c3636
Attachment #485500 - Attachment description: Let's fix the session core code too → Let's fix the session core code too [Checked in: Comment 9]
This bug should be fixed now, unless any of the following occurrences needs fixing too:
http://mxr.mozilla.org/comm-central/search?string=.wrappedJSObject&case=1&find=%2Fsuite%2F.*%5C.js%24
"Found 10 matching lines in 9 files"
Status: REOPENED → RESOLVED
Closed: 10 years ago10 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.1b2
You need to log in before you can comment on or make changes to this bug.