Clean up prompt/menu button styles and bindings

RESOLVED DUPLICATE of bug 618989

Status

Fennec Graveyard
General
RESOLVED DUPLICATE of bug 618989
7 years ago
7 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

Details

(Assignee)

Description

7 years ago
We have a common "list of buttons" UI pattern that is used for the context menu, site menu, promts/dialogs, and menulists.  Some of these use <button> elements inside vboxes; others use <richlistitem> elements, and still others use custom bindings.

Because of this, the styles for these buttons are more complicated than necessary, and the behavior is inconsistent.  For example, some of the button lists can scroll and others can't.  We should fix this by providing a single set of bindings and styles that can be used in all these places.
(Assignee)

Comment 1

7 years ago
This work is happening for bug 618989.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 618989
You need to log in before you can comment on or make changes to this bug.