div with position: fixed shows default windows bg color

VERIFIED DUPLICATE of bug 4209

Status

()

Core
CSS Parsing and Computation
P3
normal
VERIFIED DUPLICATE of bug 4209
18 years ago
18 years ago

People

(Reporter: Doron Rosenberg (IBM), Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
See attached testcases: a div with css attribute "position: fixed" has as a
bgcolor the default windows bgcolor.

regression, as this works correctly with netscape6
(Reporter)

Comment 1

18 years ago
Created attachment 19483 [details]
testcase with bug
(Reporter)

Comment 2

18 years ago
Created attachment 19484 [details]
testcase without the bug
(Reporter)

Comment 3

18 years ago
btw, this is with 2000111704 trunk, win98.
(Reporter)

Comment 4

18 years ago
this is similar to 4209, except that this works in ns6, so this was fixed once.

Comment 5

18 years ago
Hmm, after long readings through the two reports, this should be a dupe of 4209,
which should be fixed with bug 39621 patch (nsViewManager3) being activated as a
default.

I'm not sure why this could be working in NS6...  CCing roc, who owns 39621 and
nsViewManager3...

Comment 6

18 years ago
hmm, position:fixed seems to simply do not work in NS6, and so the background is
rendered like it should - but I'm also seeing no fixed position there :(

doron, can we dupe this?
"position: fixed" was removed from Netscape 6, so the submitter's comment
> this works correctly with netscape6
is not correct. This bug is a duplicate of bug 4209 and will be fixed when the 
new view manager is turned on. Marking duplicate.

*** This bug has been marked as a duplicate of 4209 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 8

18 years ago
ok, did not now about the position fixed being removed, so thought this
regressed. Verified dupe.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.